Bug 476304 - segmentation fault
segmentation fault
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: teamgit (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Terje Røsten
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-12 17:53 EST by Chitlesh GOORAH
Modified: 2009-02-06 00:24 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-06 00:24:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chitlesh GOORAH 2008-12-12 17:53:36 EST
Description of problem:
teamgit crashes with a segmentation fault.



Version-Release number of selected component (if applicable):
teamgit-0.0.8-1.fc10.i386

How reproducible:
everytime

Steps to Reproduce:
1. yum install teamgit
2. teamgit
3.
  
Actual results:
segmentation fault

Expected results:
Works as should be.


Additional info:
Comment 1 Chitlesh GOORAH 2008-12-12 17:59:06 EST
You are missing:

Requires: git

in your spec file.
Comment 2 Chitlesh GOORAH 2008-12-12 18:46:04 EST
Nevertheless double clicking on the files of the git repo makes teamgit segmentation fault again.
Comment 3 Abhijit Bhopatkar 2008-12-16 00:27:27 EST
Hi,

I am the author,

The bug is fixed in latest unstable:
Commit
http://gitorious.com/projects/teamgit/repos/mainline/commits/6ab45ef28457a54923aaf412d096f0c4d8e239b2 

Next upgrade should fix it for you.
As a workaround you can manually edit .config/www.devslashzero.com/teamgit.conf
and set correct path for git binary.

Please comment back if that doesn't work, in that case its some different bug.
Comment 4 Terje Røsten 2008-12-16 15:37:03 EST
Chitlesh, thanks for the report. Sorry about the delay.

Abhijit, when do you plan to do a release?

I can push a update, however that don't make sense if you
release  new a tarball the day after.

Anyway, thanks for being a active upstream maintainer!
Comment 5 Chitlesh GOORAH 2008-12-17 14:51:48 EST
Hello there,

I'm planning to add teamgit into the next Fedora Electronic Lab livedvd 11. If you have some suggestions on how to use teamgit or have the best git experience for CAD engineers, please do share :)

My objective is to make it easier for people to design electronics. I have already seen ASIC design centers opting for git.
Comment 6 Chitlesh GOORAH 2008-12-26 14:32:02 EST
Terje, can you please take an upstream unstable snapshot and build for fedora-updates-testing ?

having teamgit crashing on fedora is not welcoming for a git newbie like me.
Comment 7 Fedora Update System 2008-12-26 17:07:27 EST
teamgit-0.0.8-2.20081226.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/teamgit-0.0.8-2.20081226.fc9
Comment 8 Terje Røsten 2008-12-26 17:15:11 EST
Ok, updates for F9 and F10 pushed. Please test.
Comment 9 Fedora Update System 2008-12-30 18:43:20 EST
teamgit-0.0.8-2.20081226.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update teamgit'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2008-11856
Comment 10 Fedora Update System 2008-12-30 18:50:15 EST
teamgit-0.0.8-2.20081226.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing-newkey update teamgit'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-11910
Comment 11 Fedora Update System 2009-01-07 04:18:10 EST
teamgit-0.0.8-2.20081226.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2009-01-07 04:25:05 EST
teamgit-0.0.8-2.20081226.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Chitlesh GOORAH 2009-01-07 16:29:50 EST
The problem still exists.
click on the init-db, crash !
Comment 14 Terje Røsten 2009-01-08 15:12:21 EST
Yeah, most of the commands under Advanced seems to crash.

teamgit current release is 0.0.8, this is not stable software.

I guess we have to live with this problems for a while, however I will
try to update the package when new releases is available.
Comment 15 Abhijit Bhopatkar 2009-01-08 23:18:55 EST
Hi, This is the author again.

As Terje pointed out its a pre,pre alpha software :D

Anyway the latest crash reported with init-db, i assume is from "advanced" menu. As such that is toally a work in progress. And i am afraid it won't all be fixed until we painfully go through each of those and fix/blacklist them.
Comment 16 Abhijit Bhopatkar 2009-01-17 02:15:32 EST
Hi i have pushed new update with v0.0.9

Now i disable the advanced menu and give enable setting with a clear warning.
Hope this will suffies untill we get the thing stabilized

Plus ofcourse few new features....

Abhijit
Comment 17 Abhijit Bhopatkar 2009-01-21 23:09:45 EST
Ok most of the advanced menu crashes are fixed,
Unparsable manpages won't make teamgit crash anymore (hopefully :D )

Can somebody double check please?

Treje, please update the package with latest HEAD since this is def. most stable release than previous.

Abhijit
Comment 18 Fedora Update System 2009-02-06 00:24:38 EST
teamgit-0.0.9-1.20090205.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 19 Fedora Update System 2009-02-06 00:24:45 EST
teamgit-0.0.9-1.20090205.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.