Bug 476309 - Mail notification enters 100% cpu usage when it can't connect
Mail notification enters 100% cpu usage when it can't connect
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: mail-notification (Show other bugs)
10
All Linux
low Severity high
: ---
: ---
Assigned To: Dmitry Butskoy
Fedora Extras Quality Assurance
https://bugs.launchpad.net/mail-notif...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-12 18:34 EST by An. N
Modified: 2008-12-15 07:32 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-15 07:32:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 182923 None None None Never

  None (edit)
Description An. N 2008-12-12 18:34:03 EST
Description of problem:
The mail notification applet enters a 100% cpu usage state when it can't connect. I have a realtek 8169 based card, which oopses the kernel upon boot (I punched in the bug but it seems that nobody is fixing it). Since the network card doesn't work properly, there is no network connectivity available and for some reason mail notification enters this weird state.

Version-Release number of selected component (if applicable):
mail-notification-5.4-4.fc10.i386

How reproducible:
Always

Steps to Reproduce:
1. start gnome (faulty r8169 driver responsible for the network)
2. mail notification (which is autostarting with GNOME) has 100% CPU usage for some reason
3.
  
Actual results:


Expected results:
The applet displays an error icon and keeps trying to connect

Additional info:
Comment 1 Dmitry Butskoy 2008-12-15 07:32:02 EST
It looks like the old standing upstream bug https://bugs.launchpad.net/mail-notification/+bug/182923

If not, please, reopen.

Note You need to log in before you can comment on or make changes to this bug.