Bug 476314 - Insufficient communication from Fedora leadership in the event of package failure
Insufficient communication from Fedora leadership in the event of package fai...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: fedora-docs (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Paul W. Frields
Karsten Wade
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-12 19:04 EST by nicholas manojlovic
Modified: 2008-12-14 18:14 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-14 18:14:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description nicholas manojlovic 2008-12-12 19:04:35 EST
Description of problem:

Following the release of a buggy dbus package, a number of systems encountered serious problems. This bug is to address the communication failures from the Fedora leadership. There is a reasonable expectation that 
1) the Fedora project site could have been updated with details
2) the Fedora announce list could have been employed sooner
3) Explicit acknowledgement of the problems should have occurred sooner
4) a timetable should have been communicated as to when all the problems could have been fixed.

(Problems and mistakes are natural and they do occur. This bug is to address the failure in communication from the Fedora leadership.)


Version-Release number of selected component (if applicable):

n/a


How reproducible:

n/a

Steps to Reproduce:
1. n/a
2.
3.
  
Actual results:

The buggy packages were released on 7-Dec-08. An email communication was released via Fedora announce on 13-Dec-08. This communication addresses one broken package (packagekit). As yet, there has not been any acknowledgement via communication that a number of other packages are still broken. There has been no timetable communicated as to when the problems may be resolved. The Fedora project site has not been updated. The broken packages have not been documented in the 'common bugs' section of the Fedora project site. 

Expected results:

Explicit and open communication. Better use of Fedora's public-facing resources. 


Additional info:
Comment 1 Karsten Wade 2008-12-13 03:10:42 EST
Not sure  I've seen a bug filed against general project processes before.  Perhaps it belongs under the 'fedora-marketing' component?

Regardless, Paul is a more clear owner for this until a bug fixer is found, so I'm reassigning to the Fedora Project Leader.
Comment 2 Paul W. Frields 2008-12-14 18:14:41 EST
For the sake of accuracy, the announcement was made on 12-Dec.

The community has identified several issues to address here, not the least of which is how to ensure that maintainers do not accidentally break major system components.  We also need an avenue for informing users that (1) doesn't rely as heavily on their visiting specific web sites, and (2) also doesn't rely on users registering their contact information.  In this case, a notification based system might have been affected by the DBus breakage and thus ineffective.  Other solutions are being discussed on fedora-devel-list.

The D-Bus package breakage has been added to the "Common F10 bugs" wiki page.

Since these problems have been under discussion on the open community mailing lists for some time now, and we intend to have a solution in the near future, possibly before the next release of Fedora, I'm going to close as NEXTRELEASE.

Note You need to log in before you can comment on or make changes to this bug.