Bug 476323 - Evolution lost all account settings after power cut off
Evolution lost all account settings after power cut off
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
10
i386 Linux
low Severity high
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-12 20:52 EST by markm
Modified: 2009-01-07 16:36 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-07 16:36:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description markm 2008-12-12 20:52:11 EST
Description of problem:

after power cut off (was forced to do so after my computer failed to wake up from suspend) evolution lost all account settings, after restoring account, it also re-downloaded all already downloaded emails.

Version-Release number of selected component (if applicable):

evolution-2.24.2-1.fc10.i386

How reproducible:

happened once (for the first time in fedora 10, had many accidental power cut offs in Fedora 9 and Evolution has never lost any settings).

Additional info:

Why account settings are stored in keyring not together with other evolution data (such as mail / calendar)? keyring didn't get lost as my wireless internet connection worked without any problems problems after restart, but Evolution lost its account settings (together with signatures).
Comment 1 Matthew Barnes 2008-12-12 22:10:24 EST
Account settings are not stored in the keyring, they're split between GConf and your ~/.evolution directory.  Sounds like possible disk corruption to me.  I'm not sure what action to take on the Evolution side to address this.
Comment 2 markm 2008-12-13 05:42:03 EST
I am using xfs on my /home partition if that helps.

or maybe it's related to dbus and policykit issue? I've read about some structural changes to dbus and policykit which may cause other applications not to work properly. or maybe it was just one off - I am using suspend on daily basis and this is first time in years when wake up from suspend didn't work.
Comment 3 Milan Crha 2009-01-07 13:00:54 EST
I agree with Matt, I also do not see anything we can do on the Evolution side. What do you think?

Maybe you've right, maybe it was because of some changes in other modules.
Comment 4 markm 2009-01-07 14:51:14 EST
Does Evolution reads and saves account settings in GConf while it runs? If so, it might be a disk corruption, if not - it would guess changes to dbus/policy kit caused this data loss. I did have more accidental crashes since then caused by broken nvidia chip (replaced now thanks to Dell) and haven't lost any settings.

I don't like the idea of account information stored in GConf - they should be stored in ~/.evolution. I don't like the idea of evolution settings stored in GConf - every time I install new version, I have to set all settings from the scratch. I don't like the idea of GConf.
Comment 5 Matthew Barnes 2009-01-07 15:34:59 EST
So it sounds like this is a CLOSED/CANTFIX, yes?
Comment 6 markm 2009-01-07 16:36:41 EST
yep, thanks.

Note You need to log in before you can comment on or make changes to this bug.