Bug 476369 - warning: %post(plymouth-plugin-solar-0.6.0-1.fc10.i386) scriptlet failed, exit status 1
warning: %post(plymouth-plugin-solar-0.6.0-1.fc10.i386) scriptlet failed, exi...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: plymouth (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-13 13:24 EST by Bruno Wolff III
Modified: 2009-05-28 16:21 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-28 15:32:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bruno Wolff III 2008-12-13 13:24:43 EST
Description of problem:
When running livecd-creator I got the following message printed out when the solar plugin was installed:
warning: %post(plymouth-plugin-solar-0.6.0-1.fc10.i386) scriptlet failed, exit status 1
plymouth-libs, plymouth-scripts and plymouth-plugin-label had all already been installed before plymouth-plugin-solar.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.I was run livecd-creator trying to build a new games spin and was pointing to a number of local repositories for F10 including Everything, Updates, Updates-testing and one I created with some recent F10 updates that haven't made it to updates or updates-testing yet.

2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Michael Cronenworth 2008-12-15 11:55:40 EST
Strange because I updated with the plymouth-plugin-solar from updates-testing and received no errors upon package update.

plymouth-plugin-solar scripts:
$ rpm -q plymouth-plugin-solar --scripts
postinstall scriptlet (using /bin/sh):
export LIB=lib
if [ $1 -eq 1 ]; then
    /usr/sbin/plymouth-set-default-plugin solar
fi
postuninstall scriptlet (using /bin/sh):
export LIB=lib
if [ $1 -eq 0 ]; then
    if [ "$(/usr/sbin/plymouth-set-default-plugin)" == "solar" ]; then
        /usr/sbin/plymouth-set-default-plugin text
    fi
fi

Could it be that "plymouth-set-default-plugin" does not exist prior to it being called? It is contained in "plymouth-scripts-0.6.0-0.2008.11.17.3.fc10.i386" so is that being installed?
Comment 2 Bruno Wolff III 2008-12-15 13:09:43 EST
I wouldn't expect to see it on an update as the package its scripts need are likely to already be installed. It is something you would see on a fresh install or a livecd build. And even there you could get random successes in spite of a missing dependency requirement depending on the order in which packages get installed.
My guess is that some command that is used by the script wasn't installed, causing the script to fail. It looked like most or all of the intentional failure paths in the script printed an error message to stderr and I didn't see any other messages.
Comment 3 Michael Cronenworth 2008-12-15 13:56:58 EST
Bruno, please read my comment again. I listed exactly what the scripts do.

It seems there is no requirement by plymouth-plugin-solar for the plymouth-scripts package. This is the problem.
Comment 4 Bruno Wolff III 2008-12-15 14:39:53 EST
plymouth-plugin-solar requires /usr/sbin/plymouth-set-default-plugin which effectively does the same thing.
plymouth-scripts had already been installed by the time plymouth-plugin-solar was installed in the case I saw the error message, so I am not convinced a Requires(pre): plymouth-scripts will prevent this.
Comment 5 Ray Strode [halfline] 2008-12-15 16:52:22 EST
Bruno, just to be sure, you're doing a 32-bit spin on a 32-bit machine?
Comment 6 Bruno Wolff III 2008-12-15 17:03:47 EST
Yes. And both the build machine and the target are F10.
I did notice a post today of a patch on the live cd list mentioning that using --tmpdir can cause dependency problems. I am using the --tmpdir option, so perhaps what I am seeing is related to what that patch is fixing.
I can test that theory out tonight.
Comment 7 Bruno Wolff III 2008-12-15 22:08:26 EST
I tried applying the forthcoming patch to create.py from livecd-tools and I am still seeing the error message while building the games spin. So it doesn't seem to be related to the --tmpdir issue reported on the livecd list.
Comment 8 Bruno Wolff III 2009-01-03 23:55:37 EST
This is also happening in F11 (Rawhide):
  Installing: plymouth-plugin-solar        ################### [ 683/1260]
warning: %post(plymouth-plugin-solar-0.6.0-2.fc11.i386) scriptlet failed, exit status 1
Comment 9 Thomas Janssen 2009-05-28 10:12:15 EDT
I can`t reproduce it with F11 (Rawhide 1 week close to GA). Bruno does it still fail for you?

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 10 Bruno Wolff III 2009-05-28 11:47:46 EDT
I will be building a livedvd image later today and will save the output so I can look for the error message.
Comment 11 Bruno Wolff III 2009-05-28 15:32:50 EDT
I think plymouth has changed enough since the report that this can be closed. There isn't even a plymouth-plugin-solar any more (it's now plymouth-theme-solar).
I did run livecd-creator to make a custom game spin and didn't see any errors related to plymouth dependencies. The charge theme gets pulled in instead of solar. But without evidence of a bug I think it's best just to close this.
Comment 12 Thomas Janssen 2009-05-28 16:21:06 EDT
Hello

We're glad it's fixed and you're able to create your custom spins again.

I change the Status to "Closed - Worksforme".

Thank you for your contribution to Fedora.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.