Bug 476384 - New install from dvd lacks components
New install from dvd lacks components
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-13 17:17 EST by C Wallace
Modified: 2013-01-09 23:58 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-30 16:28:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/sdb10/var/log/anaconda.log (34.02 KB, text/plain)
2008-12-15 14:56 EST, C Wallace
no flags Details
sdb10/var/log/anaconda.syslog (46.43 KB, text/plain)
2008-12-15 14:57 EST, C Wallace
no flags Details
/sdb10/var/log/anaconda.xlog (79.03 KB, text/plain)
2008-12-15 14:58 EST, C Wallace
no flags Details
/SDB12/var/log/anaconda.log (25.85 KB, text/plain)
2008-12-15 15:00 EST, C Wallace
no flags Details
/SDB12/var/log/anaconda.syslog (47.36 KB, text/plain)
2008-12-15 15:00 EST, C Wallace
no flags Details
/SDB12/var/log/anaconda.xlog (78.64 KB, text/plain)
2008-12-15 15:01 EST, C Wallace
no flags Details
rpm-spyware? (1.33 KB, text/plain)
2008-12-15 15:03 EST, C Wallace
no flags Details
yum backtrace (2.41 KB, text/plain)
2008-12-15 19:20 EST, C Wallace
no flags Details

  None (edit)
Description C Wallace 2008-12-13 17:17:08 EST
Description of problem:After a new installation of FC10 from the live cd, /usr/lib/rpm, rpm-config, rpmrc and pulseaudio modules are missing.


Version-Release number of selected component (if applicable): 2.6.27.5-117.fc10.x86_64



How reproducible:


Steps to Reproduce:
1.Try to run rhythmbox
2.Run yum update in hopes of fixing rhythmbox/pulseaudio
3.Run  rpm -q --qf "%{SOURCERPM}\n" -f /bin/mount to see what ails yum

  
Actual results:No music and no updates. See attached file.


Expected results: The sweet sounds of a Bach Cantata as I explored the wonders of Fedora 10


Additional info:1  Architecture is an AMD 64x2 4850e on a Gigabyte GA-MA78GM-S2H
2  I had a freeze while trying to install Fedora with the live cd (see bug #43870), and used the workaround in that bug report.
3  The live cd checksum was ok
Comment 1 Jeremy Katz 2008-12-15 10:06:31 EST
What are the contents of /var/log/anaconda* ?  

This sounds like a bad CD or copy.   (What's the other bug # you were referencing -- it's missing a digit)
Comment 2 C Wallace 2008-12-15 14:56:14 EST
Created attachment 327008 [details]
/sdb10/var/log/anaconda.log
Comment 3 C Wallace 2008-12-15 14:57:25 EST
Created attachment 327009 [details]
sdb10/var/log/anaconda.syslog
Comment 4 C Wallace 2008-12-15 14:58:57 EST
Created attachment 327010 [details]
/sdb10/var/log/anaconda.xlog
Comment 5 C Wallace 2008-12-15 15:00:07 EST
Created attachment 327011 [details]
/SDB12/var/log/anaconda.log
Comment 6 C Wallace 2008-12-15 15:00:51 EST
Created attachment 327012 [details]
/SDB12/var/log/anaconda.syslog
Comment 7 C Wallace 2008-12-15 15:01:30 EST
Created attachment 327013 [details]
/SDB12/var/log/anaconda.xlog
Comment 8 C Wallace 2008-12-15 15:03:52 EST
Created attachment 327015 [details]
rpm-spyware?
Comment 9 C Wallace 2008-12-15 15:06:21 EST
If this is not a bug, please accept my apologies

Need real name? What's wrong with my name?
Comment 10 C Wallace 2008-12-15 16:15:03 EST
I've been through all my browser histories, and I can't find that bug number.
However, the advice I followed was:
"When the dvd install process freezes, use Alt + F2, login as root, run drakx11, accepting all default setings, then close. Then run service -f dm, install to HD, then check xorg.conf." 
In fact, I copied the xorg.conf from  my fedora 9 (which was already copied from debian and modified). X and gnome work ok, so this isn't the problem.
Comment 11 C Wallace 2008-12-15 19:20:50 EST
Created attachment 327044 [details]
yum backtrace
Comment 12 C Wallace 2008-12-15 19:22:46 EST
I thought I might solve my problem in this way:
I copied my first fc 10 installation (sdb10) into another partition, sdb13. (cp gave a swag of unknown file type and cannot stat: no such file or directory errors, all in /usr/lib and /etc)
I rm -r 'd the whole /usr/lib directory and copied a new version from the second installation (sdb12), which was more complete, and copied individually the few /etc directories and files. After editing grub.conf the third version booted ok. However running yum repolist gave:
error: Unable to open /usr/lib/rpm/rpmrc for reading: Not a directory.

And 
[cam@cwpc ~]$ ls -l /usr/lib/rpm
?--------- 65299 256 5677 117440512 1969-08-16 23:51 /usr/lib/rpm
[cam@cwpc ~]$ 
which is what I got on the first installation. Yet the /usr/lib/rpm directory which I copied has 10 items in it, and permissions 755; and so did the sdb13 installation before booting. 
I'll try downloading another live dvd.
I attach the backtrace from yum
Comment 13 C Wallace 2008-12-17 14:02:16 EST
(In reply to comment #1)
> What are the contents of /var/log/anaconda* ?  
> 
> This sounds like a bad CD or copy.   (What's the other bug # you were
> referencing -- it's missing a digit)

1    OOPS
Like an idiot, I've been saying cd when I meant dvd.

2  cam@cwpc:/$ sha1sum /dev/cdrom
f1e5ae7db6a1ba227de7294c4112385922388648  /dev/cdrom

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

f1e5ae7db6a1ba227de7294c4112385922388648 *Fedora-10-x86_64-DVD.iso
As you can see, they match
Comment 14 Chris Lumens 2009-01-05 17:08:23 EST
Can you explain exactly which steps you took in installation?  To me, it looks like you grabbed a installation DVD and then additionally checked or added a remote repo that contains Fedora packages.  The remote repo took precedence but wasn't a complete repo so the RPM package wasn't downloaded.  Your install continued but was missing that package, and you ended up with a broken install.

Does that sound about right?
Comment 15 C Wallace 2009-01-05 18:47:07 EST
Sorry, but I can't say exactly what steps I took. It was a while ago, and I didn't write everything down, as I was expecting it to 'just work' as the Fedora 9 installation did.
I _think_ on the second install attempt I just used the defaults.
I ended up comparing the /etc and /usr directories and adding the missing bits to the second install. 
I wouldn't bother for myself, as I have now got a working FC 10, but if you are really interested I still have the disc I used and I could do another install on a freshly formatted partition to see what that gives.
Comment 16 Chris Lumens 2009-01-30 16:28:31 EST
I've been unable to reproduce this issue, so I am going to close it as WORKSFORME.  In addition, I have not heard from our QA guys about this problem, which means a fair amount of testing has happened here without running into it.  If you can reliably reproduce it in the future, feel free to reopen and we can try to investigate.

Note You need to log in before you can comment on or make changes to this bug.