Bug 476397 - google gadget crashes
Summary: google gadget crashes
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: google-gadgets
Version: 10
Hardware: i386
OS: Linux
low
high
Target Milestone: ---
Assignee: Michel Alexandre Salim
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-12-14 03:36 UTC by Edmond
Modified: 2009-01-16 23:48 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-01-16 23:46:36 UTC


Attachments (Terms of Use)
crash dump from Gnome (270.61 KB, text/plain)
2008-12-14 03:36 UTC, Edmond
no flags Details

Description Edmond 2008-12-14 03:36:19 UTC
Created attachment 326841 [details]
crash dump from Gnome

Description of problem:
ggl-gtk crash when starts

Version-Release number of selected component (if applicable):
0.10.3-1

How reproducible:
100%

Steps to Reproduce:
1. run "ggl-gtk" from shell
  
Actual results:
#ggl-gtk
Not a regular file: /
4dfe624e-088f-fee9-05b474fb-38f16ccd is dumped


Expected results:
program starts and run successfully

Additional info:

Comment 1 Alex Lancaster 2008-12-14 08:26:11 UTC
I can confirm this with both ggl-gtk and ggl-qt.

Comment 2 James Su 2008-12-18 10:10:09 UTC
It because google gadgets needs to access some dbus services, like hal and network manager. But a security policy prevents it from accessing those resource. 0.10.3 assumes the access is always success, and will crash if it fails.

0.10.4 fixed this issue by checking the access result and do nothing if it fails.

However, many gadgets relies on this feature to get system information, such as battery meter, wireless monitor etc. The best way to fix this issue is to grant access right to google gadgets.

Comment 3 Edmond 2008-12-18 16:58:31 UTC
I just upgrade and confirm google gadget working again.

Thanks for the help.

Comment 4 Edward Rudd 2008-12-19 15:50:24 UTC
Any possibility of getting an updated build in testing?  This also affects x86_64 F10.

Comment 5 Michel Alexandre Salim 2009-01-01 21:33:29 UTC
(In reply to comment #2)
> It because google gadgets needs to access some dbus services, like hal and
> network manager. But a security policy prevents it from accessing those
> resource. 0.10.3 assumes the access is always success, and will crash if it
> fails.
Bizarre; I'm retesting 0.10.3-2 and while I'm getting errors, it does not crash, even after I removed ~/.google/gadgets and starting from scratch:

$ ggl-gtk
Not a regular file: /
Not a regular file: /
Not a regular file: /
No permission to read file.
No permission to access device status.
No permission to access device status.
No permissions to access D-Bus.
 
James, any specific details on which dbus services are required, so I can reassign this bug to the correct component?

(In reply to comment #4)
> Any possibility of getting an updated build in testing?  This also affects
> x86_64 F10.

An update is on the way.

Comment 6 Edward Rudd 2009-01-01 22:04:34 UTC
I tested the 0.10.3-2 as well and it indeed does not crash anymore.

Comment 7 James Su 2009-01-02 11:56:00 UTC
GGL requires HAL, network manager and dbus itself.

Upgrading to 0.10.4 is highly recommended, because it supports some new gadgets, like GMail, YouTube and Google Docs.

(In reply to comment #5)
> (In reply to comment #2)
> > It because google gadgets needs to access some dbus services, like hal and
> > network manager. But a security policy prevents it from accessing those
> > resource. 0.10.3 assumes the access is always success, and will crash if it
> > fails.
> Bizarre; I'm retesting 0.10.3-2 and while I'm getting errors, it does not
> crash, even after I removed ~/.google/gadgets and starting from scratch:
> 
> $ ggl-gtk
> Not a regular file: /
> Not a regular file: /
> Not a regular file: /
> No permission to read file.
> No permission to access device status.
> No permission to access device status.
> No permissions to access D-Bus.
> 
> James, any specific details on which dbus services are required, so I can
> reassign this bug to the correct component?
> 
> (In reply to comment #4)
> > Any possibility of getting an updated build in testing?  This also affects
> > x86_64 F10.
> 
> An update is on the way.

Comment 8 Fedora Update System 2009-01-07 09:24:25 UTC
google-gadgets-0.10.4-2.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing-newkey update google-gadgets'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2009-0143

Comment 9 Fedora Update System 2009-01-07 09:27:32 UTC
google-gadgets-0.10.4-2.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update google-gadgets'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-0172

Comment 10 James Su 2009-01-08 10:11:38 UTC
google gadgets 0.10.5 is available. It's mainly a bugfix version. Feel free to upgrade your package.

Comment 11 Fedora Update System 2009-01-16 23:46:31 UTC
google-gadgets-0.10.4-2.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2009-01-16 23:48:38 UTC
google-gadgets-0.10.4-2.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.