Bug 476405 - extension not registered after install
Summary: extension not registered after install
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: php-pecl-ssh2
Version: 10
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Itamar Reis Peixoto
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-12-14 09:23 UTC by Remi Collet
Modified: 2009-01-16 23:45 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-01-16 23:45:50 UTC
Type: ---


Attachments (Terms of Use)

Description Remi Collet 2008-12-14 09:23:08 UTC
Description of problem:
extension not registered after install because package.xml is a V1 file

Version-Release number of selected component (if applicable):
0.10-2.fc9


How reproducible:
always

Steps to Reproduce:
1. yum install php-pecl-ssh2
2. pecl list
  
Actual results:
(no packages installed from channel pecl.php.net)

Expected results:
Installed packages, channel pecl.php.net:
=========================================
Package   Version State
ssh2      0.10    beta

Additional info:
Solution is to convert package.xml to V2 using

%{__pear} convert package.xml package2.xml

And use it to register the extensionin %post(un)

Also note than version 0.11.0 is out (patch for libssh2 no more required)

Comment 1 Itamar Reis Peixoto 2008-12-20 17:54:10 UTC
I agree, the xml needs to be converted

also in the version 0.11.0 there are no xml file, :-( , someone forget to include this file ?

Comment 2 Remi Collet 2008-12-20 19:01:52 UTC
> I agree, the xml needs to be converted

And probably a bug filed upstream...

> also in the version 0.11.0 there are no xml file, :-( , someone forget to include this file ?

$ tar tzf /tmp/ssh2-0.11.0.tgz 
package.xml
ssh2-0.11.0/config.m4
ssh2-0.11.0/ssh2.c
ssh2-0.11.0/php_ssh2.h
ssh2-0.11.0/ssh2_fopen_wrappers.c
ssh2-0.11.0/ssh2_sftp.c

No problem for me.

Comment 3 Itamar Reis Peixoto 2008-12-20 23:07:09 UTC
Can you test this version ?

http://koji.fedoraproject.org/koji/taskinfo?taskID=1012609

Comment 4 Remi Collet 2008-12-21 10:41:46 UTC
That's seems ok (can't really test because i'm actually running php 5.3.0-dev).

Comment 5 Fedora Update System 2008-12-21 19:11:39 UTC
php-pecl-ssh2-0.11.0-1.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/php-pecl-ssh2-0.11.0-1.fc9

Comment 6 Fedora Update System 2008-12-24 18:43:25 UTC
php-pecl-ssh2-0.11.0-1.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing-newkey update php-pecl-ssh2'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-11790

Comment 7 Fedora Update System 2009-01-16 23:45:47 UTC
php-pecl-ssh2-0.11.0-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.