Bug 476442 - mount cifs blocked for more than 120 seconds with a call trace
mount cifs blocked for more than 120 seconds with a call trace
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Jeff Layton
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-14 13:46 EST by kc8hfi
Modified: 2014-06-18 03:38 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-15 06:50:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description kc8hfi 2008-12-14 13:46:34 EST
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.4) Gecko/2008102920 Firefox/3.0.4

I have a samba automount set up, and when I launch konqueror, it hangs.  konqueror is configured to open ~ by default, and the automount share is set to ~/fileserver.  I can do an ls on that automount share from a terminal, and it sits there doing nothing.  Doing ls on any of the local filesystems is ok.  



Reproducible: Sometimes

Steps to Reproduce:
1.click on the automounted share to get it mounted up
2.wait awhile, launch konqueror and it hangs up
3.then try to plug in a flash drive thats formatted fat32 and dmesg doesn't even see it as plugged in
Actual Results:  
cannot use konqueror because it hangs up.  Cannot mount flash drives, mounting cd's is ok.

Expected Results:  
konqueror launches successfully and able to browse all filesystems that are mounted.  

Dec 14 10:35:52 charlie kernel: INFO: task mount.cifs:26905 blocked for more than 120 seconds.
Dec 14 10:35:52 charlie kernel: "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.
Dec 14 10:35:52 charlie kernel: mount.cifs    D c201dc80     0 26905  26904
Dec 14 10:35:52 charlie kernel:        eecaed24 00200082 c201dc80 c201dc80 00200286 eecaecf4 c0632a7c f0d07080 
Dec 14 10:35:52 charlie kernel:        f0d072dc c201dc80 00000001 eecae000 b550e3a5 08b31918 c201dc80 f0d07080 
Dec 14 10:35:52 charlie kernel:        00000000 00000000 00000000 ffffffff 7fffffff 7fffffff eecaed88 eecaed64 
Dec 14 10:35:52 charlie kernel: Call Trace:
Dec 14 10:35:52 charlie kernel:  [<c0632a7c>] ? kprobe_flush_task+0x4f/0x85
Dec 14 10:35:52 charlie kernel:  [<c062ed06>] schedule_timeout+0x16/0x8b
Dec 14 10:35:52 charlie kernel:  [<c0431a23>] ? prepare_signal+0x12d/0x159
Dec 14 10:35:52 charlie kernel:  [<c062eae5>] wait_for_common+0xbe/0x109
Dec 14 10:35:52 charlie kernel:  [<c041f972>] ? default_wake_function+0x0/0xd
Dec 14 10:35:52 charlie kernel:  [<c062ebb2>] wait_for_completion+0x12/0x14
Dec 14 10:35:52 charlie kernel:  [<c0438a34>] kthread_stop+0x51/0x70
Dec 14 10:35:52 charlie kernel:  [<f8dacf90>] cifs_mount+0x1c20/0x1ea1 [cifs]
Dec 14 10:35:52 charlie kernel:  [<c0497022>] ? get_filesystem+0x12/0x2d
Dec 14 10:35:52 charlie kernel:  [<f8da074c>] cifs_get_sb+0xd6/0x203 [cifs]
Dec 14 10:35:52 charlie kernel:  [<c048689b>] vfs_kern_mount+0x81/0xf7
Dec 14 10:35:52 charlie kernel:  [<c0486955>] do_kern_mount+0x32/0xb9
Dec 14 10:35:52 charlie kernel:  [<c04995c0>] do_new_mount+0x46/0x71
Dec 14 10:35:52 charlie kernel:  [<c049979b>] do_mount+0x1b0/0x1ce
Dec 14 10:35:52 charlie kernel:  [<c04692f1>] ? __get_free_pages+0x1b/0x21
Dec 14 10:35:52 charlie kernel:  [<c04977b7>] ? copy_mount_options+0x27/0x10b
Dec 14 10:35:52 charlie kernel:  [<c049981d>] sys_mount+0x64/0x9b
Dec 14 10:35:52 charlie kernel:  [<c0404bde>] syscall_call+0x7/0xb
Dec 14 10:35:52 charlie kernel:  =======================
Dec 14 10:40:22 charlie kernel: INFO: task mount.cifs:26905 blocked for more than 120 seconds.
Dec 14 10:40:22 charlie kernel: "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.
Dec 14 10:40:22 charlie kernel: mount.cifs    D c201dc80     0 26905  26904
Dec 14 10:40:22 charlie kernel:        eecaed24 00200082 c201dc80 c201dc80 00200286 eecaecf4 c0632a7c f0d07080 
Dec 14 10:40:22 charlie kernel:        f0d072dc c201dc80 00000001 eecae000 b550e3a5 08b31918 c201dc80 f0d07080 
Dec 14 10:40:22 charlie kernel:        00000000 00000000 00000000 ffffffff 7fffffff 7fffffff eecaed88 eecaed64 
Dec 14 10:40:22 charlie kernel: Call Trace:
Dec 14 10:40:22 charlie kernel:  [<c0632a7c>] ? kprobe_flush_task+0x4f/0x85
Dec 14 10:40:22 charlie kernel:  [<c062ed06>] schedule_timeout+0x16/0x8b
Dec 14 10:40:22 charlie kernel:  [<c0431a23>] ? prepare_signal+0x12d/0x159
Dec 14 10:40:22 charlie kernel:  [<c062eae5>] wait_for_common+0xbe/0x109
Dec 14 10:40:22 charlie kernel:  [<c041f972>] ? default_wake_function+0x0/0xd
Dec 14 10:40:22 charlie kernel:  [<c062ebb2>] wait_for_completion+0x12/0x14
Dec 14 10:40:22 charlie kernel:  [<c0438a34>] kthread_stop+0x51/0x70
Dec 14 10:40:22 charlie kernel:  [<f8dacf90>] cifs_mount+0x1c20/0x1ea1 [cifs]
Dec 14 10:40:22 charlie kernel:  [<c0497022>] ? get_filesystem+0x12/0x2d
Dec 14 10:40:22 charlie kernel:  [<f8da074c>] cifs_get_sb+0xd6/0x203 [cifs]
Dec 14 10:40:22 charlie kernel:  [<c048689b>] vfs_kern_mount+0x81/0xf7
Dec 14 10:40:22 charlie kernel:  [<c0486955>] do_kern_mount+0x32/0xb9
Dec 14 10:40:22 charlie kernel:  [<c04995c0>] do_new_mount+0x46/0x71
Dec 14 10:40:22 charlie kernel:  [<c049979b>] do_mount+0x1b0/0x1ce
Dec 14 10:40:22 charlie kernel:  [<c04692f1>] ? __get_free_pages+0x1b/0x21
Dec 14 10:40:22 charlie kernel:  [<c04977b7>] ? copy_mount_options+0x27/0x10b
Dec 14 10:40:22 charlie kernel:  [<c049981d>] sys_mount+0x64/0x9b
Dec 14 10:40:22 charlie kernel:  [<c0404bde>] syscall_call+0x7/0xb
Dec 14 10:40:22 charlie kernel:  =======================
Comment 1 Simo Sorce 2008-12-14 13:59:19 EST
kernel stack trace == kernel problem
reassigning
Comment 2 Jeff Layton 2008-12-14 15:05:05 EST
What kernel version is this?
Comment 3 kc8hfi 2008-12-14 23:24:18 EST
Its kernel 2.6.26.6-49.fc8
Comment 4 Jeff Layton 2008-12-15 06:50:57 EST
I believe you're hitting one of several races in the CIFS mount/unmount codepath. These were recently fixed upstream with a rather substantial set of patches for 2.6.28. It was also backported for 2.6.27.9 was released late last week and should fix this problem (and many others).

I'm going to close this with a resolution of NEXTRELEASE since I believe it will be fixed in f9 and f10 when 2.6.27.9 is released for them. It looks doubtful that f8 will get that kernel, so you may want to consider upgrading to a newer fedora release.

Note You need to log in before you can comment on or make changes to this bug.