Bug 476476 - regression: lspci missing from anaconda in minstg2.img
Summary: regression: lspci missing from anaconda in minstg2.img
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda
Version: 5.3
Hardware: All
OS: Linux
low
high
Target Milestone: rc
: ---
Assignee: Anaconda Maintenance Team
QA Contact: Alexander Todorov
URL:
Whiteboard:
: 528749 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-12-15 04:49 UTC by Wade Mealing
Modified: 2018-10-20 02:30 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-02 09:55:32 UTC
Target Upstream Version:


Attachments (Terms of Use)
this is a fix the anaconda for this bug (358 bytes, patch)
2009-04-16 14:29 UTC, Levente Farkas
no flags Details | Diff


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2009:1306 0 normal SHIPPED_LIVE anaconda bug fix and enhancement update 2009-09-01 10:20:11 UTC

Description Wade Mealing 2008-12-15 04:49:20 UTC
Description of problem:

Under low memory conditions anaconda will attempt to fetch the secondary minstg2.img instead of the usual stage2.img file.

The anaconda script referenced requires the lspci binary to be made available.  The lspci binary is available in the stage2.img but not the minstg2.img.

This makes anaconda crash if it is in an xen or vmware instance.


Version-Release number of selected component (if applicable):

RHEL 5.3 snap 5.

Steps to Reproduce:
1. create vmware guest, 256mb ram.
2. Boot vmware instance, rhel 5.3 snap 5.
3. Wait.
  
Actual results:

Anaconda fails with OSError no such file or directory.

Expected results:

Anaconda to find lspci and continue on its merry way.

Additional info:

Python traceback:

Traceback (most recent call first):
  File "/usr/lib/python2.4/subprocess.py", line 975, in _execute_child
    raise child_exception
  File "/usr/lib/python2.4/subprocess.py", line 542, in __init__
    errread, errwrite)
  File "/usr/lib/anaconda/iutil.py", line 488, in inVmware
    proc = subprocess.Popen(lspci, stdout = subprocess.PIPE)
  File "/usr/lib/anaconda/yuminstall.py", line 860, in doGroupSetup
    if iutil.inXen() or iutil.inVmware() or \
  File "/usr/lib/anaconda/yuminstall.py", line 942, in doRepoSetup
    self.doGroupSetup()
  File "/usr/lib/anaconda/backend.py", line 172, in doRepoSetup
    anaconda.backend.doRepoSetup(anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 201, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 124, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/text.py", line 721, in run
    anaconda.dispatch.gotoNext()
  File "/usr/bin/anaconda", line 1006, in ?
    anaconda.intf.run(anaconda)
OSError: [Errno 2] No such file or directory

This only happens to the minstg2.img

14:22:42 INFO    : 255560 kB are available
14:22:42 WARNING : URLINSTALL falling back to non-GUI stage2 due to insufficient RAM
14:22:42 INFO    : transferring ftp://192.168.1.1//5.3-snap5/tree/images/minstg2.img to a fd

Comment 3 Wade Mealing 2009-02-18 00:57:05 UTC
For those on the CC,

The quick work around is to install the system with 512 or greater MB of ram.

Comment 4 Kelsey Hightower 2009-03-04 02:51:07 UTC
I ran into this same problem using VM Fusion 2.1 on Mac OS 10.5.6. I was able to work around the issue by allocating at least 296 MB of ram, any thing less than 296 would reproduce the error.

Comment 5 Per Sjoholm 2009-04-06 18:52:04 UTC
Tried to install 5.3-i386(CentOS) via netboot on a 256 MB system.

On some system it's not feasibel  to add more memory. Laptops or older HW with expensive or hard to get memory.

Any idea how to do with 128Mb or 192Mb ?
I have some Vectra 200 PentiumPro that takes a max of 192.
Does 5 5.1 5.2 have the same problem?
Install older version and them upgrade ?

Comment 6 Wade Mealing 2009-04-07 01:19:09 UTC
Gday Per,

Its been a while since I worked this original problem, but I did find a solution in rebuilding/adding the minstg2.img file.

# This is from memory, I'm not at work right now.

modprobe squashfs
mkdir -p /mnt/stage2
mount minstg2.img /mnt/stage2 -t squashfs -o loop,rw
cp /sbin/lspci /mnt/stage2/
umount /mnt/stage2


Wade

Comment 7 Per Sjoholm 2009-04-07 14:29:17 UTC
Hi Wade,
your solution is not complete, you have to use mksquashfs from squashfs-tools

I did
Copy DVD to dir C53-i386
unsquashfs -v C53-i386/images/minstg2.img
           -> squashfs-root/

mount -t squashfs -o loop C53-i386/images/stage2.img stage2
cp /mnt/stage2/usr/sbin/lspci squashfs-root/usr/sbin/
mksquashfs squashfs-root/ minstg2.img
cp minstg2.img C53-i386/images/

umount stage2 

mount --bind -o context=system_u:object_r:httpd_sys_content_t C53-i386 \
       /var/www/Linux/C53-i386

Installation works OK

Thanks.

/Per

Comment 8 Levente Farkas 2009-04-16 14:29:27 UTC
Created attachment 339848 [details]
this is a fix the anaconda for this bug

Comment 9 RHEL Program Management 2009-05-19 17:30:42 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 11 Chris Lumens 2009-05-19 18:12:59 UTC
This should be fixed in 11.1.2.176-1.

Comment 14 Alexander Todorov 2009-05-29 11:49:16 UTC
Hi,
I tested with i386/xen/pv guest with 256MB of memory.

While on RHEL 5.3 I didn't get a traceback (happens in VMWare only I guess) switching to tty2 revealed that lspci was missing. 

With latest RHEL5.4 and anaconda-11.1.2.179-1 I can confirm that lspci is present in minstg2.img

Comment 16 errata-xmlrpc 2009-09-02 09:55:32 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1306.html

Comment 19 Chris Lumens 2009-10-13 15:05:41 UTC
*** Bug 528749 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.