Bug 476485 - Unlock Screen fails
Unlock Screen fails
Status: CLOSED DUPLICATE of bug 394181
Product: Fedora
Classification: Fedora
Component: kdebase-workspace (Show other bugs)
10
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-15 02:27 EST by Ian Amess
Modified: 2008-12-15 06:08 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-15 06:08:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ian Amess 2008-12-15 02:27:11 EST
Description of problem:
After update of kdebase-workspace unlocking screen fails. Either a message is displayed "Unable to unlock session because Authentication System failed; you must kill krunner_lock (pid number) manually", or kcheckpass just seems to hang. On the odd occasion session will be unlocked.

Version-Release number of selected component (if applicable):
kdebase-workspace-4.1.3-7.fc10

How reproducible:
Mostly reproducible, however will sometimes work.

Steps to Reproduce:
1.Lock session
2.Attempt to unlock session
3.
  
Actual results:
Behaviour as described above

Expected results:
Session is unlocked

Additional info:
Comment 1 Kevin Kofler 2008-12-15 04:15:17 EST
This is almost certainly NOT caused by the kdebase-workspace update, but by the dbus update.
Comment 2 Ian Amess 2008-12-15 04:35:25 EST
Possibly except I have updated DBus to the reverted change,

dbus-1.2.4-2.fc10
dbus-x11-1.2.4-2.fc10
dbus-libs-1.2.4-2.fc10

And also I never noticed this behaviour until I ran a package update yesterday
this included the following:

Dec 14 09:40:37 Updated: system-config-services-0.99.28-3.fc10.noarch
Dec 14 09:40:42 Updated: liberation-fonts-1.04.92-1.fc10.noarch
Dec 14 09:40:51 Updated: glibc-2.9-3.i686
Dec 14 09:40:57 Updated: 7:kdegraphics-libs-4.1.3-3.fc10.i386
Dec 14 09:40:59 Updated: 2:gimp-libs-2.6.3-2.fc10.i386
Dec 14 09:41:01 Updated: loudmouth-1.4.3-1.fc10.i386
Dec 14 09:41:26 Updated: glibc-common-2.9-3.i386
Dec 14 09:41:48 Updated: amarok-2.0-2.fc10.i386
Dec 14 09:42:07 Updated: 2:gimp-2.6.3-2.fc10.i386
Dec 14 09:42:18 Updated: kipi-plugins-0.2.0-0.6.beta4.fc10.i386
Dec 14 09:42:20 Installed: lensfun-0.2.3-2.fc10.i386
Dec 14 09:42:20 Updated: ksysguardd-4.1.3-7.fc10.i386
Dec 14 09:42:24 Updated: libchewing-0.3.2-0.fc10.i386
Dec 14 09:42:24 Updated: 2:gimp-help-browser-2.6.3-2.fc10.i386
Dec 14 09:42:30 Updated: 7:kdegraphics-4.1.3-3.fc10.i386
Dec 14 09:42:32 Updated: 2:irqbalance-0.55-12.fc10.i386
Dec 14 09:42:35 Updated: nscd-2.9-3.i386
Dec 14 09:42:37 Updated: iproute-2.6.27-1.fc10.i386
Dec 14 09:42:38 Updated: dcraw-8.89-1.fc10.i386
Dec 14 09:42:40 Updated: gawk-3.1.6-2.fc10.i386
Dec 14 09:42:43 Updated: glibc-headers-2.9-3.i386
Dec 14 09:42:45 Updated: glibc-devel-2.9-3.i386
Dec 14 09:42:45 Updated: digikam-libs-0.10.0-0.7.beta6.fc10.i386
Dec 14 09:42:46 Updated: kdebase-workspace-libs-4.1.3-7.fc10.i386
Dec 14 09:42:59 Updated: kdebase-workspace-4.1.3-7.fc10.i386
Dec 14 09:43:12 Updated: digikam-0.10.0-0.7.beta6.fc10.i386
Comment 3 Kevin Kofler 2008-12-15 04:48:25 EST
But the only change between kdebase-workspace-4.1.3-6 and -7 is this:
http://cvs.fedoraproject.org/viewvc/rpms/kdebase-workspace/F-10/kdebase-workspace-4.1.4-krunnerhistory.patch?revision=1.1&view=markup

I don't see how that change can cause this bug.

So I'm pretty lost there. Have you rebooted after "upgrading" to the reverted dbus? The D-Bus system daemon is only restarted by a full reboot, a logout is not sufficient.
Comment 4 Ian Amess 2008-12-15 04:57:55 EST
I've rebooted several times. I am also unable to find any error messages in either .xsession-errors or anywhere else, any suggestions on how to debug this?
Comment 5 Ian Amess 2008-12-15 05:49:20 EST
I think I have found the cause of this, I had installed the thinkfinger package and added the thinkfinger module to /etc/pam.d/system-auth

auth        required      pam_env.so
auth        sufficient    pam_thinkfinger.so
auth        sufficient    pam_unix.so nullok try_first_pass
auth        requisite     pam_succeed_if.so uid >= 500 quiet
auth        required      pam_deny.so

If I take the thinkfinger module out then Screen unlock will work again. This only seems to cause a problem with krunner_lock not seen it anywhere else.
Comment 6 Ian Amess 2008-12-15 06:08:08 EST

*** This bug has been marked as a duplicate of bug 394181 ***

Note You need to log in before you can comment on or make changes to this bug.