Bug 476490 - "yum remove openldap / db4" wants to remove all packages
"yum remove openldap / db4" wants to remove all packages
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
10
i386 Linux
low Severity high
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-15 03:38 EST by Wilfried Spillemaeckers
Modified: 2014-01-21 18:07 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-15 05:47:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wilfried Spillemaeckers 2008-12-15 03:38:12 EST
Description of problem:
Wanted to remove openldap or db4 (related to another bug I filed).  When trying "yum remove openldap" or "yum remove db4" I was offered to remove 945 packages.  I checked a few of these and they were the latest once installed (for instance yum itself). I did not go through with it so cannot say if they would indeed be removed.


Version-Release number of selected component (if applicable):


How reproducible: "yum remove openldap", "yum remove db4"


Steps to Reproduce:
1.
2.
3.
  
Actual results: too many packages selected for removal


Expected results: only the packages indicated to be removed


Additional info: this makes a workaround for another bug (openldap bdb) impossible and makes my whole authentication impossible.
Comment 1 Wilfried Spillemaeckers 2008-12-15 03:40:00 EST
Since this bug in combination with other bug openldap bdb related makes LDAP unworkable on FC10, the upgrade from FC8 to FC10 has failed and I need to roll back on my production machines.
Comment 2 Panu Matilainen 2008-12-15 05:47:20 EST
This is not a bug, doing anything else would be a bug, these packages have a huge amount of very real dependencies. Try 'rpm -e --test openldap db4' to see the direct dependencies, yum processes these recursively (like it should) to remove everything that depends on db4 and openldap, everything depending on those packages in turn etc.

'rpm -e --nodeps db4 openldap' will only remove those two packages but don't be surprised when everything and the world breaks if you do so.
Comment 3 Wilfried Spillemaeckers 2008-12-15 06:06:20 EST
OK. Understood.  Which makes my other bug report 476488 more serious, as openldap and bdb cannot be removed without breaking the system as you say.

Note You need to log in before you can comment on or make changes to this bug.