Bug 476494 - pidgin crashes periodically, probably because of pulseaudio
pidgin crashes periodically, probably because of pulseaudio
Status: CLOSED DUPLICATE of bug 470000
Product: Fedora
Classification: Fedora
Component: pidgin (Show other bugs)
10
All Linux
low Severity high
: ---
: ---
Assigned To: Warren Togami
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-15 04:10 EST by Pavel Rosenboim
Modified: 2008-12-15 13:00 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-15 13:00:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavel Rosenboim 2008-12-15 04:10:36 EST
Description of problem:
Pidgin crashes after few hours running. When run from console, I see following messages:
[pasha@pashar ~]$ pidgin 
E: shm.c: mmap() failed: Cannot allocate memory
E: shm.c: mmap() failed: Cannot allocate memory
E: shm.c: mmap() failed: Cannot allocate memory
E: shm.c: mmap() failed: Cannot allocate memory
E: shm.c: mmap() failed: Cannot allocate memory
E: shm.c: mmap() failed: Cannot allocate memory
E: shm.c: mmap() failed: Cannot allocate memory
E: shm.c: mmap() failed: Cannot allocate memory
E: shm.c: mmap() failed: Cannot allocate memory
E: shm.c: mmap() failed: Cannot allocate memory
E: shm.c: mmap() failed: Cannot allocate memory
E: shm.c: mmap() failed: Cannot allocate memory
E: shm.c: mmap() failed: Cannot allocate memory
E: shm.c: mmap() failed: Cannot allocate memory
E: shm.c: mmap() failed: Cannot allocate memory
E: shm.c: mmap() failed: Cannot allocate memory
E: shm.c: mmap() failed: Cannot allocate memory
E: shm.c: mmap() failed: Cannot allocate memory
E: shm.c: mmap() failed: Cannot allocate memory
E: shm.c: mmap() failed: Cannot allocate memory
E: shm.c: mmap() failed: Cannot allocate memory
E: shm.c: mmap() failed: Cannot allocate memory
E: shm.c: mmap() failed: Cannot allocate memory
E: shm.c: mmap() failed: Cannot allocate memory
E: shm.c: mmap() failed: Cannot allocate memory
E: shm.c: mmap() failed: Cannot allocate memory
E: shm.c: mmap() failed: Cannot allocate memory
E: shm.c: mmap() failed: Cannot allocate memory
E: shm.c: mmap() failed: Cannot allocate memory
E: shm.c: mmap() failed: Cannot allocate memory
E: shm.c: mmap() failed: Cannot allocate memory
E: shm.c: mmap() failed: Cannot allocate memory
E: shm.c: mmap() failed: Cannot allocate memory
E: shm.c: mmap() failed: Cannot allocate memory
E: shm.c: mmap() failed: Cannot allocate memory
E: shm.c: mmap() failed: Cannot allocate memory
E: shm.c: mmap() failed: Cannot allocate memory
E: shm.c: mmap() failed: Cannot allocate memory
E: shm.c: mmap() failed: Cannot allocate memory
E: shm.c: mmap() failed: Cannot allocate memory
E: shm.c: mmap() failed: Cannot allocate memory
E: shm.c: mmap() failed: Cannot allocate memory
E: shm.c: mmap() failed: Cannot allocate memory
E: shm.c: mmap() failed: Cannot allocate memory
E: shm.c: mmap() failed: Cannot allocate memory
E: shm.c: mmap() failed: Cannot allocate memory
E: shm.c: mmap() failed: Cannot allocate memory
E: shm.c: mmap() failed: Cannot allocate memory
E: shm.c: mmap() failed: Cannot allocate memory
E: shm.c: mmap() failed: Cannot allocate memory
E: shm.c: mmap() failed: Cannot allocate memory
E: shm.c: mmap() failed: Cannot allocate memory
E: shm.c: mmap() failed: Cannot allocate memory
E: shm.c: mmap() failed: Cannot allocate memory
E: shm.c: mmap() failed: Cannot allocate memory
E: shm.c: mmap() failed: Cannot allocate memory
E: shm.c: mmap() failed: Cannot allocate memory
E: shm.c: mmap() failed: Cannot allocate memory
E: shm.c: mmap() failed: Cannot allocate memory
E: shm.c: mmap() failed: Cannot allocate memory
E: shm.c: mmap() failed: Cannot allocate memory
E: shm.c: mmap() failed: Cannot allocate memory
E: shm.c: mmap() failed: Cannot allocate memory
E: shm.c: mmap() failed: Cannot allocate memory
E: shm.c: mmap() failed: Cannot allocate memory
E: shm.c: mmap() failed: Cannot allocate memory
E: shm.c: mmap() failed: Cannot allocate memory
E: shm.c: mmap() failed: Cannot allocate memory
E: shm.c: mmap() failed: Cannot allocate memory
E: shm.c: mmap() failed: Cannot allocate memory
E: shm.c: mmap() failed: Cannot allocate memory
E: shm.c: mmap() failed: Cannot allocate memory
E: shm.c: mmap() failed: Cannot allocate memory
E: shm.c: mmap() failed: Cannot allocate memory
E: shm.c: mmap() failed: Cannot allocate memory
E: shm.c: mmap() failed: Cannot allocate memory
E: shm.c: mmap() failed: Cannot allocate memory
E: shm.c: mmap() failed: Cannot allocate memory
pidgin: pulse.c:203: pulse_new: Assertion `p->context' failed.
Pidgin 2.5.2-6.fc10 has segfaulted and attempted to dump a core file.
This is a bug in the software and has happened through
no fault of your own.

If you can reproduce the crash, please notify the developers
by reporting a bug at:
http://developer.pidgin.im/simpleticket/

Please make sure to specify what you were doing at the time
and post the backtrace from the core file.  If you do not know
how to get the backtrace, please read the instructions at
http://developer.pidgin.im/wiki/GetABacktrace

If you need further assistance, please IM either SeanEgn or 
LSchiere (via AIM).  Contact information for Sean and Luke 
on other protocols is at
http://developer.pidgin.im/wiki/DeveloperPages

Version-Release number of selected component (if applicable):
pidgin-2.5.2-6.fc10.i386

How reproducible:
Always

Steps to Reproduce:
1. Run pidgin, wait few hours
2.
3.
  
Actual results:
Crash.
Comment 1 Pavel Rosenboim 2008-12-15 07:59:56 EST
Backtrace:

Core was generated by `pidgin'.
Program terminated with signal 11, Segmentation fault.
[New process 29617]
[New process 28550]
[New process 28970]
[New process 29613]
[New process 29254]
[New process 29616]
[New process 29286]
[New process 28986]
[New process 28982]
[New process 29483]
[New process 29546]
[New process 29110]
[New process 29466]
[New process 29502]
[New process 29344]
[New process 29000]
[New process 29448]
[New process 29085]
[New process 29161]
[New process 29319]
[New process 29387]
[New process 28992]
[New process 29102]
[New process 29513]
[New process 29363]
[New process 29237]
[New process 29262]
[New process 29424]
[New process 29530]
[New process 29075]
[New process 29404]
[New process 29067]
[New process 29013]
[New process 29475]
[New process 28978]
[New process 29605]
[New process 29612]
[New process 29458]
[New process 28529]
[New process 29379]
[New process 29355]
#0  abort () at abort.c:124
124           ABORT_INSTRUCTION;
Missing separate debuginfos, use: debuginfo-install libtdb-1.1.1-23.fc10.i386
(gdb) bt full
#0  abort () at abort.c:124
        act = {__sigaction_handler = {sa_handler = 0, sa_sigaction = 0},
  sa_mask = {__val = {4294967295 <repeats 32 times>}}, sa_flags = 0,
  sa_restorer = 0}
        sigs = {__val = {32, 0 <repeats 31 times>}}
#1  0x080c63fb in sighandler (sig=11) at gtkmain.c:193
No locals.
#2  <signal handler called>
No symbol table info available.
#3  0x00e2af9e in FindElfTextSection ()
    at ../google-breakpad/src/common/linux/file_id.cc:60
        elf_header = (const <anonymous struct> *) 0xffffffff
        sections = <value optimized out>
        string_section = <value optimized out>
#4  google_breakpad::FileID::ElfFileIdentifier (this=0x2dceba0c,
    identifier=0x2dceca38 "XÊÎ-2¸â")
    at ../google-breakpad/src/common/linux/file_id.cc:111
        fd = 116
        st = {st_dev = 16, __pad1 = 0, st_ino = 6663195, st_mode = 33024,
  st_nlink = 1, st_uid = 500, st_gid = 500, st_rdev = 0, __pad2 = 0,
  st_size = 67108904, st_blksize = 4096, st_blocks = 24, st_atim = {
    tv_sec = 1229340118, tv_nsec = 611645837}, st_mtim = {tv_sec = 1229340113,
    tv_nsec = 968770561}, st_ctim = {tv_sec = 1229340113,
---Type <return> to continue, or q <return> to quit---
    tv_nsec = 968770561}, __unused4 = 0, __unused5 = 0}
        base = (void *) 0xffffffff
        success = <value optimized out>
#5  0x00e2945f in WriteCVRecord (minidump_writer=<value optimized out>,
    module=0x2dceca88, module_path=0x2dcecd50 "/dev/shm/pulse-shm-4204736888")
    at ../google-breakpad/src/client/linux/handler/minidump_generator.cc:550
        cv = {<google_breakpad::UntypedMDRVA> = {writer_ = 0x168f1738,
    position_ = 196352, size_ = 45}, data_ = {cv_signature = 1396986706,
    signature = {data1 = 0, data2 = 0, data3 = 0,
      data4 = "\000\000\000\000\000\000\000"}, age = 0, pdb_file_name = ""},
  allocation_state_ = google_breakpad::TypedMDRVA<MDCVInfoPDB70>::SINGLE_OBJECT_WITH_ARRAY}
        module_name = 0x2dcecd59 "pulse-shm-4204736888"
        file_id = {
  path_ = "/dev/shm/pulse-shm-4204736888", '\0' <repeats 4066 times>}
        identifier = "XÊÎ-2¸â\0008\027\217\026PÍÎ-"
#6  0x00e2a492 in ModuleInfoCallback (module_info=@0x2dcecd50,
    context=0x2dcecf14)
    at ../google-breakpad/src/client/linux/handler/minidump_generator.cc:594
        module = {base_of_image = 223293440, size_of_image = 67112960,
  checksum = 0, time_date_stamp = 0, module_name_rva = 196288, version_info = {
    signature = 0, struct_version = 0, file_version_hi = 0,
    file_version_lo = 0, product_version_hi = 0, product_version_lo = 0,
---Type <return> to continue, or q <return> to quit---
    file_flags_mask = 0, file_flags = 0, file_os = 0, file_type = 0,
    file_subtype = 0, file_date_hi = 0, file_date_lo = 0}, cv_record = {
    data_size = 45, rva = 196352}, misc_record = {data_size = 0, rva = 0},
  reserved0 = {0, 0}, reserved1 = {0, 0}}
        loc = {data_size = 64, rva = 196288}
#7  0x00e2d93c in google_breakpad::LinuxThread::ListModules (this=0x168f1744,
    callback_param=0x2dcecf24)
    at ../google-breakpad/src/client/linux/handler/linux_thread.cc:330
        module = {
  name = "/dev/shm/pulse-shm-4204736888", '\0' <repeats 226 times>,
  start_addr = 223293440, size = 67112960}
        line = "0d4f3000-114f4000 rw-s 00000000 00:10 6663195    /dev/shm/pulse-shm-4204736888\000\000udioconvert.so\000\000\000jpeg.so", '\0' <repeats 148 times>, "\233$\\", '\0' <repeats 37 times>, "À\237]\000ÈÌÎ- iB\tüÌÎ-n)\\", '\0' <repeats 18 times>, "\215A\t", '\0' <repeats 12 times>, "tT]\000,*oeQy+\003)\000\000\000°4â\000H3â\000\000\000\000\000a", '\0' <repeats 11 times>...
        module_count = 443
        fp = (FILE *) 0x9c43200
        start_addr = 223293440
        end_addr = <value optimized out>
#8  0x00e29258 in WriteModuleListStream (minidump_writer=0x168f1738,
    writer_args=0x168f1714, dir=0x2dcecfc8)
    at ../google-breakpad/src/client/linux/handler/minidump_generator.cc:619
---Type <return> to continue, or q <return> to quit---
        list = {<google_breakpad::UntypedMDRVA> = {writer_ = 0x168f1738,
    position_ = 90168, size_ = 56164}, data_ = {number_of_modules = 520,
    modules = {{base_of_image = 0, size_of_image = 0, checksum = 0,
        time_date_stamp = 0, module_name_rva = 0, version_info = {
          signature = 0, struct_version = 0, file_version_hi = 0,
          file_version_lo = 0, product_version_hi = 0, product_version_lo = 0,
          file_flags_mask = 0, file_flags = 0, file_os = 0, file_type = 0,
          file_subtype = 0, file_date_hi = 0, file_date_lo = 0}, cv_record = {
          data_size = 0, rva = 0}, misc_record = {data_size = 0, rva = 0},
        reserved0 = {0, 0}, reserved1 = {0, 0}}}},
  allocation_state_ = google_breakpad::TypedMDRVA<MDRawModuleList>::SINGLE_OBJECT_WITH_ARRAY}
        module_count = <value optimized out>
        context = {minidump_writer = 0x168f1738, writer_args = 0x168f1714,
  list = 0x2dcece94, module_index = 442}
        callback = {call_back = 0xe2a3d0 <ModuleInfoCallback>,
  context = 0x2dcecf14}
#9  0x00e298f9 in Write (argument=0x168f1714)
    at ../google-breakpad/src/client/linux/handler/minidump_generator.cc:758
        minidump_writer = (google_breakpad::MinidumpFileWriter *) 0x168f1738
        header = {<google_breakpad::UntypedMDRVA> = {writer_ = 0x168f1738,
    position_ = 0, size_ = 32}, data_ = {signature = 1347241037,
    version = 42899, stream_count = 6, stream_directory_rva = 32,
---Type <return> to continue, or q <return> to quit---
    checksum = 0, time_date_stamp = 1229340119, flags = 0},
  allocation_state_ = google_breakpad::TypedMDRVA<MDRawHeader>::SINGLE_OBJECT}
        dir = {<google_breakpad::UntypedMDRVA> = {writer_ = 0x168f1738,
    position_ = 32, size_ = 72}, data_ = {stream_type = 0, location = {
      data_size = 0, rva = 0}},
  allocation_state_ = google_breakpad::TypedMDRVA<MDRawDirectory>::ARRAY}
        dir_index = 1
        local_dir = {stream_type = 4, location = {data_size = 56164,
    rva = 90168}}
#10 0x006c104e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130
No locals.
Comment 2 Warren Togami 2008-12-15 13:00:52 EST

*** This bug has been marked as a duplicate of bug 470000 ***

Note You need to log in before you can comment on or make changes to this bug.