Bug 47652 - Install stops when trying to do kickstart from ftp
Install stops when trying to do kickstart from ftp
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-06 08:56 EDT by Hanne Munkholm
Modified: 2007-04-18 12:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-17 16:16:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hanne Munkholm 2001-07-06 08:56:07 EDT
Description of Problem:

I made a kickstart file with url set to our own ftp server, and I made a
bootnet.img disk, where I modified the ks entry to point to my kickstart
file.

When booting from the modified bootnet.img floppy, it finds the network
(DHCP), it finds the kickstart file (on an nfs drive), and I think it also
finds the ftp server. But very short after start, it crashes. The anaconda
error message says I should please eport the bug as soon as possible, so,
you've asked for it.

This is the file it saved on a floppy for me:
http://www.it-c.dk/~hm/tmp/anacdump.txt

My kickstart file: http://www.it-c.dk/~hm/tmp/kickstart.ks

My syslinux.cfg from bootnet.img: http://www.it-c.dk/~hm/tmp/syslinux.cfg

Sorry if I'm beeing stupid, I have no previous experience with kickstart.
Comment 1 Brent Fox 2001-07-06 14:33:37 EDT
I don't understand why you needed to modify the bootnet.img.
Comment 2 Hanne Munkholm 2001-07-09 03:22:00 EDT
I modify syslinux.cfg to tell it where on the net to find my kickstart file.
According to the RedHat Linux KickStart HOWTO I need to do either this, or make
room for the kickstart file on the floppy itself by deleting some unneccesary
drivers.
Comment 3 Brent Fox 2001-07-10 00:13:23 EDT
No, you should be able to make a boot floppy with the standard bootnet.img. 
Then, mount that floppy and copy your kickstart file to it.  Then, boot off the
floppy and then type 'linux ks=floppy' at the syslinux bootup screen.  It is
possible to pass the options to syslinux at the bootup screen...you should not
have to modify the syslinux.cfg file at all.

If you can point me in the direction of the HOWTO that you read, I'll try to get
it corrected.
Comment 4 Hanne Munkholm 2001-07-12 03:22:47 EDT
http://mirrors.sunsite.dk/ldp/HOWTO/KickStart-HOWTO.html

No it does not say I have to modify the boot disk. It says

a) If there is not enough space on the floppy, I have to. There is not. So I
have to.

b) If I want to make it easy for myself, I can make ks the default. 

Why are we discusing this?  Do you think that is the problem? I do not. To me
this is a minor detail, I understand what I've done to the syslinux.cfg and why.
Unless you can convince me that modifying syslinux.cfg on a bootdisk makes
anaconda die, because it is supposed to have a specific size, ot whatever, (and
that would be a stupid thing to do with a clear text configuration file) then I
do _not_ believe this is a problem.

I included that file for completeness.

Anyway, I'll solve my own problem, I didn't expect any help here. I just send
that bug report because the error screen specifically said you would appreciate
it, ok? Thank you very much for you time.
Comment 5 Brent Fox 2001-07-17 16:16:30 EDT
I think what you need is to put an "=" sign between the "--location" and the
"mbr" in the kickstart file, so that the line says:
'lilo --location=mbr'.  
The docs are not very clear about what needs '=' signs and what doesn't

I asked about what you modified on the boot disk because we get a fair number of
bug reports that are caused by people doing customized tasks (such as modifying
the comps file and replacing the packages that we shipped with newer ones). 
Sometimes they do things wrong, which creates a bug that looks like it's the
installer's fault.  I was just trying to figure out the level of modification
that you had done.  From your first post, it is not clear that you modified only
the syslinux.cfg file, which is a minor change.  I was wondering if you had
modified the loader itself to have the location of the kickstart file hard coded
(which would be a major change).
Comment 6 Hanne Munkholm 2001-07-18 03:15:07 EDT
I found the error. It was in the kickstart config file. I needed a "part / 
--size 1000 --grow" or something like that - mkkickstart had only made a "part"
entry for the swap partition. 

So - the installer crashes in the above situation. I've solved my problem. Up to
you if you want the installer to have more meaningful behaviour in the above
sitution, and if maybe mkkickstart should be fixed to include the root partition
and not only the swap partition.

;)

Note You need to log in before you can comment on or make changes to this bug.