Bug 476546 - mkinitrd fails to assemble my LVM on a striped root disk.
mkinitrd fails to assemble my LVM on a striped root disk.
Status: CLOSED DUPLICATE of bug 476818
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
10
All Linux
low Severity high
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-15 10:12 EST by Harald Hoyer
Modified: 2009-02-03 07:47 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-03 07:47:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Updated mkinitrd which hopefuly fixes this (47.21 KB, text/plain)
2009-02-03 06:00 EST, Hans de Goede
no flags Details

  None (edit)
Description Harald Hoyer 2008-12-15 10:12:17 EST
initrd's init is missing:

rmparts sdb
rmparts sda
dm create isw_bfadchbffa_Volume0 0 624990720 striped 2 256 8:0 0 8:16 0
dm partadd isw_bfadchbffa_Volume0

to assemble my striped raid array before scanning for logical volumes.

# dmsetup table
DATA-lvol0: 0 195330048 linear 8:37 384
DATA-lvol0: 195330048 195330048 linear 8:38 384
DATA-lvol0: 390660096 195330048 linear 8:39 384
DATA-lvol0: 585990144 193355776 linear 8:40 384
VolGroup00-cryptharald: 0 312934400 linear 253:2 311624064
isw_bfadchbffa_Volume0: 0 624990720 striped 2 256 8:0 0 8:16 0
VolGroup00-luks--swap: 0 8388608 linear 253:2 303235456
VolGroup00-LogVol01: 0 274595840 linear 253:2 28639616
swap: 0 8388608 crypt aes-cbc-essiv:sha256 0000000000000000000000000000000000000000000000000000000000000000 0 253:6 0
VolGroup00-LogVol00: 0 28639232 linear 253:2 384
_dev_mapper_VolGroup00-cryptharald: 0 312932344 crypt aes-cbc-essiv:sha256 0000000000000000000000000000000000000000000000000000000000000000 0 253:5 2056
data: 0 779344888 crypt aes-cbc-essiv:sha256 00000000000000000000000000000000 0 253:7 1032
isw_bfadchbffa_Volume0p2: 0 624575070 linear 253:0 401625
isw_bfadchbffa_Volume0p1: 0 401562 linear 253:0 63

# lvm pvdisplay
...
  --- Physical volume ---
  PV Name               /dev/dm-2
  VG Name               VolGroup00
  PV Size               297.82 GB / not usable 8.30 MB
  Allocatable           yes (but full)
  PE Size (KByte)       32768
  Total PE              9530
  Free PE               0
  Allocated PE          9530
  PV UUID               u9pVSD-Sijl-UbM0-hknN-nhyT-d22L-5lF5A8


Happy to provide more information and a login.
Comment 1 Harald Hoyer 2009-02-03 05:50:01 EST
PING!
This is still an issue for my F10 machine!
Comment 2 Harald Hoyer 2009-02-03 05:55:18 EST
# dmraid -ay -t
isw_bfadchbffa_Volume0: 0 624989696 striped 2 256 /dev/sda 0 /dev/sdb 0
isw_bfadchbffa_Volume0p1: 0 401562 linear /dev/mapper/isw_bfadchbffa_Volume0 63
isw_bfadchbffa_Volume0p2: 0 624575070 linear /dev/mapper/isw_bfadchbffa_Volume0 401625

# dmsetup table
DATA-lvol0: 0 195330048 linear 8:37 384
DATA-lvol0: 195330048 195330048 linear 8:38 384
DATA-lvol0: 390660096 195330048 linear 8:39 384
DATA-lvol0: 585990144 193355776 linear 8:40 384
VolGroup00-cryptharald: 0 312934400 linear 253:2 311624064
isw_bfadchbffa_Volume0: 0 624990720 striped 2 256 8:0 0 8:16 0
VolGroup00-luks--swap: 0 8388608 linear 253:2 303235456
VolGroup00-LogVol01: 0 274595840 linear 253:2 28639616
swap: 0 8388608 crypt aes-cbc-essiv:sha256 0000000000000000000000000000000000000000000000000000000000000000 0 253:6 0
VolGroup00-LogVol00: 0 28639232 linear 253:2 384
_dev_mapper_VolGroup00-cryptharald: 0 312932344 crypt aes-cbc-essiv:sha256 0000000000000000000000000000000000000000000000000000000000000000 0 253:5 2056
data: 0 779344888 crypt aes-cbc-essiv:sha256 00000000000000000000000000000000 0 253:7 1032
isw_bfadchbffa_Volume0p2: 0 624575070 linear 253:0 401625
isw_bfadchbffa_Volume0p1: 0 401562 linear 253:0 63
Comment 3 Hans de Goede 2009-02-03 06:00:28 EST
Created attachment 330724 [details]
Updated mkinitrd which hopefuly fixes this
Comment 4 Harald Hoyer 2009-02-03 06:12:17 EST
Not yet completely ... the LVM scan is missing..

 rmparts sda
 dm create isw_bfadchbffa_Volume0 0 624990720 striped 2 256 8:0 0 8:16 0
 dm partadd isw_bfadchbffa_Volume0
-echo Scanning logical volumes
-lvm vgscan --ignorelockingfailure
-echo Activating logical volumes
-lvm vgchange -ay --ignorelockingfailure  VolGroup00
+resume /dev/mapper/swap
 echo Creating root device.
 mkrootdev -t ext3 -o defaults,ro /dev/VolGroup00/LogVol00
 echo Mounting root filesystem.
 mount /sysroot
Comment 5 Hans de Goede 2009-02-03 07:47:19 EST
Duping this to the main tracker bug for this issue now, thanks for all your help.

*** This bug has been marked as a duplicate of bug 476818 ***

Note You need to log in before you can comment on or make changes to this bug.