Bug 476547 - Cannot build Bacula, missing Python.h
Cannot build Bacula, missing Python.h
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: bacula (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Andreas Thienemann
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-15 10:12 EST by Jon Ciesla
Modified: 2008-12-15 22:44 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-15 22:44:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix building with Python 2.6 (1.43 KB, patch)
2008-12-15 13:52 EST, Ignacio Vazquez-Abrams
no flags Details | Diff

  None (edit)
Description Jon Ciesla 2008-12-15 10:12:24 EST
<snip>

checking for varargs.h... 
no
checking for Python support... 
no
configure: error: Unable to find Python.h in standard locations
error: Bad exit status from /var/tmp/rpm-tmp.mQXlg1 (%build)
    Bad exit status from /var/tmp/rpm-tmp.mQXlg1 (%build)
RPM build errors:
Child returncode was: 1
EXCEPTION: Command failed. See logs for output.
 # ['bash', '--login', '-c', 'rpmbuild -bb --target x86_64 --nodeps builddir/build/SPECS/bacula.spec']
Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/mock/trace_decorator.py", line 70, in trace
    result = func(*args, **kw)
  File "/usr/lib/python2.4/site-packages/mock/util.py", line 316, in do
    raise mock.exception.Error, ("Command failed. See logs for output.\n # %s" % (command,), child.returncode)
Error: Command failed. See logs for output.
 # ['bash', '--login', '-c', 'rpmbuild -bb --target x86_64 --nodeps builddir/build/SPECS/bacula.spec']
LEAVE do --> EXCEPTION RAISED


Can provide more logs as needed, not sure what would be most helpful.  python-devel is BuildRequired.
Comment 1 James Antill 2008-12-15 12:35:29 EST
 The only thing that comes to mind is that maybe you are looking for /usr/include/python2.5/Python.h instead of /usr/include/python2.6/Python.h ?
 If not that, please attach the mock log files.
Comment 2 Ignacio Vazquez-Abrams 2008-12-15 13:52:37 EST
Created attachment 327003 [details]
Patch to fix building with Python 2.6
Comment 3 Jon Ciesla 2008-12-15 16:05:20 EST
Ah, looks great.  Thanks Ignacio, building now.
Comment 4 Jon Ciesla 2008-12-15 16:14:10 EST
That does not appear to have helped:

checking for varargs.h... 
no
checking for Python support... 
no
configure: error: Unable to find Python.h in standard locations
error: Bad exit status from /var/tmp/rpm-tmp.WDdkJf (%build)
    Bad exit status from /var/tmp/rpm-tmp.WDdkJf (%build)
RPM build errors:
Child returncode was: 1
EXCEPTION: Command failed. See logs for output.
 # ['bash', '--login', '-c', 'rpmbuild -bb --target i386 --nodeps builddir/build/SPECS/bacula.spec']
Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/mock/trace_decorator.py", line 70, in trace
    result = func(*args, **kw)
  File "/usr/lib/python2.4/site-packages/mock/util.py", line 316, in do
    raise mock.exception.Error, ("Command failed. See logs for output.\n # %s" % (command,), child.returncode)
Error: Command failed. See logs for output.
 # ['bash', '--login', '-c', 'rpmbuild -bb --target i386 --nodeps builddir/build/SPECS/bacula.spec']
LEAVE do --> EXCEPTION RAISED


Full logs at http://koji.fedoraproject.org/koji/taskinfo?taskID=1000629
Comment 5 Ignacio Vazquez-Abrams 2008-12-15 17:26:16 EST
That's because there's a typo on line 10 of your version of the patch.
Comment 6 Jon Ciesla 2008-12-15 22:44:06 EST
<facepalm>.  Good catch.  After the day I at at work today, I'm surprised the thing wasn't COBOL. . .

Built successfully.

Note You need to log in before you can comment on or make changes to this bug.