Bug 476561 - ntop: update to version 3.3.9 / 3.3.10
ntop: update to version 3.3.9 / 3.3.10
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: ntop (Show other bugs)
el5
All Linux
low Severity medium
: ---
: ---
Assigned To: Huzaifa S. Sidhpurwala
Fedora Extras Quality Assurance
UpdatePackage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-15 12:15 EST by Jose Pedro Oliveira
Modified: 2009-12-07 01:30 EST (History)
3 users (show)

See Also:
Fixed In Version: 3.3.9-7.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-07 01:30:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jose Pedro Oliveira 2008-12-15 12:15:04 EST
Description of problem:
The latest upstream version is 3.3.9.
The current EPEL5 version is ntop-3.3.6.
The current rawhide version is ntop-3.3.8.

Expected results:
Version 3.3.9 in EPEL5.

Additional info:
http://www.ntop.org/
http://sourceforge.net/projects/ntop/
Comment 1 Rakesh Pandit 2009-01-08 09:18:35 EST
I maintain packages for fedora repos only. Will request someone to update for EPEL5 between.
Comment 2 Huzaifa S. Sidhpurwala 2009-01-12 22:02:40 EST
taking this.
Comment 3 Rakesh Pandit 2009-01-13 10:54:26 EST
Huzaifa import 3.3.8 for now 3.3.9 requires investigation about GeoLiteCity data binary form it downloads while building. It also downloads GeoIP but that is present in fedora repo. Need to investigate the license issues with GeoLiteCity and package it so that we can update on later stage. I would like to keep ntop 3.3.8 for now.
Comment 4 Rakesh Pandit 2009-01-16 22:58:38 EST
GeoLiteCity is not worth packaging. The CSV file is some 100MB and we cannot even think of importing 28 MB binary. I will rather wait for more stable 4.0.0 :) Will close once Huzafas imports in EPEL5.

Thanks.
Comment 5 Peter Vrabec 2009-03-17 06:59:45 EDT
Hi Huzaifa, if I get commit permissions, I'll do the update for EPEL.
Comment 6 Michael Stahnke 2009-06-17 21:25:39 EDT
Any update on this?
Comment 7 Jose Pedro Oliveira 2009-08-28 22:39:08 EDT
ping

Current upstream version: 3.3.10
Current rawhide version:  3.3.10
Current EPEL version:     3.3.6
Comment 8 Jose Pedro Oliveira 2009-08-29 18:49:38 EDT
FYI: ntop 3.3.9 can be built for epel but ntop 3.3.10 can't due to the new libevent requirement (libevent version >= 1.4):


ntop 3.3.10
----
...
checking for event_get_version in -levent... no
Error! You need to have libevent 1.4.X or better.
...
----
Comment 9 Jose Pedro Oliveira 2009-08-29 21:00:11 EDT
Could someone please build ntop-3.3.9-5 for EPEL5?

The source files can be the ones available in the CVS F-11 branch. It only requires a specfile modification: the line specifying the tcp_wrappers BR must be changed as RHEL still uses a monolithic tcp_wrappers package (no tcp_wrappers-devel subpackage).

tia,
jpo
Comment 10 Jose Pedro Oliveira 2009-10-23 19:05:06 EDT
ping
Comment 11 Huzaifa S. Sidhpurwala 2009-10-25 23:05:39 EDT
There was an issue with koji and the ntop build, which is sorted now, will look into building it for EL-5 now.
Comment 12 Fedora Update System 2009-10-26 01:32:55 EDT
ntop-3.3.9-7.el5 has been submitted as an update for Fedora EPEL 5.
http://admin.fedoraproject.org/updates/ntop-3.3.9-7.el5
Comment 13 Huzaifa S. Sidhpurwala 2009-10-26 01:33:49 EDT
Hi Jose, 
Can you test the update, so that it can be pushed to stable. Thanks.
Comment 14 Fedora Update System 2009-10-26 12:53:12 EDT
ntop-3.3.9-7.el5 has been pushed to the Fedora EPEL 5 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ntop'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/EL-5/FEDORA-EPEL-2009-0739
Comment 15 Jose Pedro Oliveira 2009-10-31 17:06:49 EDT
(In reply to comment #13)
> Hi Jose, 
> Can you test the update, so that it can be pushed to stable. Thanks.  

I updated ntop two days ago to the latest EPEL version (3.3.9-7.el5.i386)
and it has been running without problems.

/jpo
Comment 16 Fedora Update System 2009-12-07 01:30:53 EST
ntop-3.3.9-7.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.