Bug 476562 - extended list option for rhncfg client
extended list option for rhncfg client
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: Clients (Show other bugs)
0.6
All Linux
low Severity medium
: ---
: ---
Assigned To: Pradeep Kilambi
Red Hat Satellite QA List
:
Depends On:
Blocks: space04
  Show dependency treegraph
 
Reported: 2008-12-15 12:30 EST by Pradeep Kilambi
Modified: 2009-09-17 03:06 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-17 03:06:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pradeep Kilambi 2008-12-15 12:30:18 EST
Test/Add extended list (elist) option to rhncfg client which provides an ls-esque style output. (Proposed by Colin.Coe)
Comment 1 Pradeep Kilambi 2008-12-15 12:31:12 EST
Usage: /usr/bin/rhncfg-client MODE [ --server-name name ] [ params ]
Valid modes are:
	diff
	get
	list
	elist
	channels
	verify
[root@config_client]# rhncfg-client elist
Mode          Owner Group          Size Rev      Config Channel    File
-rwsrwxrwx     root root             15   1                prad    /tmp/blah.txt
-rwsrwxrwx     root root             15   2                prad    /tmp/foo.txt
Comment 2 Pradeep Kilambi 2008-12-15 12:45:01 EST
man pages updated:

diff --git a/client/tools/rhncfg/config_client/rhncfg-client.sgml b/client/tools
index ba944d2..41484f3 100644
--- a/client/tools/rhncfg/config_client/rhncfg-client.sgml
+++ b/client/tools/rhncfg/config_client/rhncfg-client.sgml
@@ -61,6 +61,16 @@
         </listitem>
     </varlistentry>
     <varlistentry>
+        <term>elist</term>
+        <listitem>
+            <para>
+              List the configuration files for the machine and the labels
+              of the config channels containing them which provides an
+              ls-esque style output. Used alone.
+            </para>
+        </listitem>
+    </varlistentry>
+    <varlistentry>
         <term>get <replaceable>CONFIG_FILEPATH</replaceable></term>
         <listitem>
             <para>
@@ -112,6 +122,7 @@
 <RefSect1><Title>Examples/Summary</Title>
 <simplelist>
         <member><command>&RHNCFGC; list</command></member>
+        <member><command>&RHNCFGC; elist</command></member>
         <member><command>&RHNCFGC; get /etc/foo.conf</command></member>
         <member><command>&RHNCFGC; channels</command></member>
         <member><command>&RHNCFGC; diff</command></member>
Comment 3 Pradeep Kilambi 2009-01-15 12:04:41 EST
FAILS_QA.. looks like this dint make it into the latest package in the repo
Comment 4 Pradeep Kilambi 2009-01-15 12:18:09 EST
new packages built.. fix should be in rhncfg*-0.4.2-1
Comment 5 Miroslav Suchý 2009-09-17 03:06:41 EDT
Spacewalk 0.4 has been released for some time.

Note You need to log in before you can comment on or make changes to this bug.