Bug 476565 - yum update of kernel doesn't make the newly installed kernel the default
yum update of kernel doesn't make the newly installed kernel the default
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-15 13:09 EST by Leszek Matok
Modified: 2014-09-24 17:51 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-17 07:44:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Leszek Matok 2008-12-15 13:09:50 EST
Every since F10-Preview, when I install a new kernel, it gets added to grub.conf to the top of list, but "default" option is changed from 0 to 1, making my current kernel the default. I have to manually correct this mistake after the installation.

In F9 and below, updating kernel made it the default. This is no longer the case.

Is this on purpose?
Comment 1 Andre Robatino 2008-12-15 20:51:18 EST
I did a clean install of F10, and when I installed the new kernel-2.6.27.7-134.fc10, grub made it the default as usual.
Comment 2 Leszek Matok 2008-12-16 02:26:28 EST
Yeah, this isn't a clean install - it was upgraded with yum and I have an old grub.conf (still has a menu). Should I attach it?

Or maybe it does that only for kernel-PAE?
Comment 3 Peter Jones 2008-12-16 16:06:58 EST
What do you have in /etc/sysconfig/kernel ?
Comment 4 Leszek Matok 2008-12-16 16:27:16 EST
Oh...

DEFAULTKERNEL=kernel

I moved to kernel-PAE a month before upgrading to Rawhide (at Preview timeframe), it's totally possible that I haven't updated the kernel during that month, or haven't noticed the problem back then.

Okay, so let's say it's my fault, but on the other hand, I have no "kernel" in my system and the currently running kernel is always kernel-PAE.

Can't new-kernel-pkg be a little more automatic? I guess using something like
rpm -qf `grubby --default-kernel` --qf '%{name}'
should be enough for most of people anyhow, not to mention checking if my "DEFAULTKERNEL" is installed at all...

Can I at least ask for it to print a warning if DEFAULTKERNEL is different that the one currently being the default? This would be harmless (no possible system breakage due to no behavior change, no PackageKit users even noticing...), at the same time providing some insight into what's going to happen for the brave ones like me, who install different kernels with yum :)

Thanks and sorry for not knowing about /etc/sysconfig/kernel.
Comment 5 Hans de Goede 2009-02-17 07:44:01 EST
Closing as notabug per comment #4.

Note You need to log in before you can comment on or make changes to this bug.