Bug 476580 - libsmbios-2.0.1-2.fc10.1.src.rpm requires 'dot' capabilities not in rawhide graphviz
libsmbios-2.0.1-2.fc10.1.src.rpm requires 'dot' capabilities not in rawhide g...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: libsmbios (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Michael E Brown
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-15 16:19 EST by R P Herrold
Modified: 2009-07-14 10:34 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-14 10:34:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description R P Herrold 2008-12-15 16:19:48 EST
Description of problem:

libsmbios-2.0.1-2.fc10.1.src.rpm requires 'dot' capabilities not in rawhide graphviz

Version-Release number of selected component (if applicable):

libsmbios-2.0.1-2.fc10.1
[herrold@centos-5 graphviz]$ rpm -qa graphviz\*
graphviz-2.20.3-1orc.1
graphviz-graphs-2.20.3-1orc.1
graphviz-doc-2.20.3-1orc.1

(This is the current RawHide versions for each)


How reproducible:

rpmbuild --rebuild libsmbios-2.0.1-2.fc10.1.src.rpm

Steps to Reproduce:

observe the error messages:

Format: "png" not recognized. Use one of: canon cmap cmapx cmapx_np dia dot eps fig hpgl imap imap_np ismap mif mp pcl pic plain plain-ext ps ps2 svg svgz tk vml vmlz vtx xdot
Problems running dot. Check your installation!


hundreds will appear as .png generation capabilities are not in the graphviz
  
Actual results:

failed documention build, not detected, but lacking .png images

Expected results:

working and complete build, or detection of the issue by libsmbios in a 'make test' phase

Additional info:

Please let me know if you need additional information

-- Russ herrold
Comment 1 Michael E Brown 2008-12-15 18:31:55 EST
Any idea what happened to dot? Is it in a new RPM?
Comment 2 R P Herrold 2008-12-15 22:33:37 EST
I suspect that the 'graphviz' (provider of 'dot') is new to RawHide
and RHEL -- previously I have had to patch forward from a version in
SL -- and was pleased to see it in RawHide (assumedly on the way into
Fedora, or better RHEL 6 ;)

I am not aware or a free-standing version of 'dot' outside of 'graphviz'
Comment 3 Bug Zapper 2009-06-09 06:16:36 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 R P Herrold 2009-07-14 10:34:08 EDT
issue seems to be solved in the current rawHide .... closing

Note You need to log in before you can comment on or make changes to this bug.