Bug 476593 - RFE"done entry in install.log
RFE"done entry in install.log
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-15 19:03 EST by Ray Todd Stevens
Modified: 2009-01-07 12:16 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-07 12:16:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ray Todd Stevens 2008-12-15 19:03:54 EST
I have a problem with the install.log.   Now this may seem picky, but it would have helped with with another issue.   I had an install that was not finishing and because it was rebooting, I didn't realize that.  

How about in the install.log an entry when the final processing starts and another when it ends and it is ready to reboot.
Comment 1 Ray Todd Stevens 2008-12-28 17:33:12 EST
This is really a seperate "bug", but it was caused by bug 476372.
Comment 2 Chris Lumens 2009-01-05 16:13:07 EST
The anaconda.log file writes a line for every step of the install process, so you would definitely get a line in there once it starts doing postinstall configuration - things like writing out the bootloader, writing the anaconda-ks.cfg file, etc.  Is there a specific reason you also need something written to install.log?
Comment 3 Ray Todd Stevens 2009-01-05 17:28:44 EST
Well this has to do with another bug I reported, 476372.   When you look at the install log at the end you can't figure out if the entire install was successful, or if there was an error what went to a retry/abort screen that then abort/rebooted when you didn't get to it in time.   If the install has progressed to a certain point where the reboot produces a working system you don't know you had a problem.
Comment 4 Ray Todd Stevens 2009-01-05 17:32:08 EST
Is the anaconda.log stored somewhere that is available after the process is over that I can check?   That might fix the problem, but the reason for suggesting the install.log is that this is the only permanent record of the install that I know of.
Comment 5 Chris Lumens 2009-01-06 10:01:22 EST
Ah, I see the problem now.  The log files are only copied over to the installed system at the end, if the installation completes.  So you'd find /var/log/anaconda.log.  However, install.log is written to /root as the install progresses.  So it is possible to get partially written install.log files, but you'll never see the /var/log/anaconda.log unless the install worked.

I'll go ahead and add something in to the install.log.
Comment 6 Chris Lumens 2009-01-07 12:16:53 EST
The next build of anaconda will include a line written to install.log at the end of all package installation and upgrades.

Note You need to log in before you can comment on or make changes to this bug.