Bug 476657 - It is not possible to use two independent screens anymore
It is not possible to use two independent screens anymore
Status: CLOSED DUPLICATE of bug 464896
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
10
All Linux
medium Severity high
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-16 09:18 EST by David Tardon
Modified: 2008-12-19 19:25 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-19 19:01:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf (1.92 KB, text/plain)
2008-12-16 09:18 EST, David Tardon
no flags Details
Xorg.0.log of Xorg 1.5.2 (from F-9) (46.60 KB, text/plain)
2008-12-16 09:20 EST, David Tardon
no flags Details
Xorg.0.log of Xorg 1.5.3 (from F-10) (4.54 MB, text/plain)
2008-12-16 09:20 EST, David Tardon
no flags Details
Xorg.0.log of Xorg 1.5.3 when booted with nomodeset (98.06 KB, text/plain)
2008-12-18 02:28 EST, David Tardon
no flags Details

  None (edit)
Description David Tardon 2008-12-16 09:18:54 EST
Created attachment 327102 [details]
xorg.conf

Description of problem:
After upgrading to F-10, Xorg doesn't recognize my dual-head configuration for
two independent screens and displays the same image on both monitors. If I go back
to F-9 Xserver and ATI driver, it works OK, so it's plainly a regression.

Version-Release number of selected component (if applicable):
xorg-x11-server-Xorg-1.5.3-6.fc10.x86_64
xorg-x11-drv-ati-6.9.0-61.fc10.x86_64

Version-Release number of working component:
xorg-x11-server-Xorg-1.5.2-3.fc9.x86_64
xorg-x11-drv-ati-6.8.0-19.fc9.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. Have a dual-head ATI graphic card and two monitors.
2. Install above-mentioned F-10 xorg-x11-* packages.
3. Copy attached xorg.conf to /etc/X11/xorg.conf .
4. Start X.
  
Actual results:
One screen mirrored on both monitors is shown.

Expected results:
Two independent screens are shown, one on each of the monitors.

Additional info:
Don't say to me I should use RandR and one virtual screen. I _want_ two independent screens.
Comment 1 David Tardon 2008-12-16 09:20:03 EST
Created attachment 327103 [details]
Xorg.0.log of Xorg 1.5.2 (from F-9)
Comment 2 David Tardon 2008-12-16 09:20:47 EST
Created attachment 327104 [details]
Xorg.0.log of Xorg 1.5.3 (from F-10)
Comment 3 Matej Cepl 2008-12-17 18:38:00 EST
*** Bug 476783 has been marked as a duplicate of this bug. ***
Comment 4 Dave Airlie 2008-12-18 01:39:37 EST
does booting with nomodeset on the kernel command line bring back the old behaviour?
Comment 5 Roland McGrath 2008-12-18 01:56:22 EST
This report does not seem to be the same problem as my report (bug 476783) at all.
As I reported, it does either clone mode or two-screens mode just the same as it did before.  My only problem is the colors on the second screen.  Booting with nomodeset disables the fancy graphical boot, so the second monitor stays off during booting, but once X (gdm) starts it behaves exactly as I reported before.
Comment 6 David Tardon 2008-12-18 02:19:17 EST
dtardon->airlied: Yes, it does. Thanks!
Comment 7 David Tardon 2008-12-18 02:28:06 EST
Created attachment 327300 [details]
Xorg.0.log of Xorg 1.5.3 when booted with nomodeset
Comment 8 Matěj Cepl 2008-12-19 19:01:56 EST

*** This bug has been marked as a duplicate of bug 464896 ***

Note You need to log in before you can comment on or make changes to this bug.