Bug 476665 - Gnome freeze using Firefox
Gnome freeze using Firefox
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
10
i386 Linux
low Severity high
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-16 09:57 EST by Emanuele Bellini
Modified: 2018-04-11 05:10 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-09 09:51:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
My xorg.conf file (594 bytes, text/plain)
2008-12-16 11:50 EST, Emanuele Bellini
no flags Details
My Xorg.0.log file (61.17 KB, text/plain)
2008-12-16 11:53 EST, Emanuele Bellini
no flags Details

  None (edit)
Description Emanuele Bellini 2008-12-16 09:57:51 EST
Description of problem:
I went to this site using Firefox in Fedora 10:

http://gstreamer.freedesktop.org/features/

After a few time Gnome was frozen and I couldn't restart it. I think is a Gnome problem because there was no sign of a kernel failure (the blinking caps lock) and the music in Rhythmbox kept on playing... Maybe I'm wrong.
Of course, I don't want Firefox to work... Actually I do but, more important, Gnome should, at least letting me restart it.


Version-Release number of selected component (if applicable):
Gnome 2.24.2
Firefox 3.0.4
Fedora 10


Steps to Reproduce:
1. Launch Firefox
2. Go to: http://gstreamer.freedesktop.org/features/
3. Enjoy!

  
Actual results:
My gnome freezes (until I can move the cursor nothing works, some time after I can't!), and yours?


Expected results:
I can peacefully read that page!
Comment 1 Ray Strode [halfline] 2008-12-16 11:23:39 EST
Can you attach your xorg.conf (if you have one) and /var/log/Xorg.0.log ?
Comment 2 Emanuele Bellini 2008-12-16 11:50:33 EST
Created attachment 327130 [details]
My xorg.conf file
Comment 3 Emanuele Bellini 2008-12-16 11:53:12 EST
Created attachment 327131 [details]
My Xorg.0.log file

From the directory: /var/log/
Comment 4 Emanuele Bellini 2008-12-16 11:54:33 EST
Comment on attachment 327130 [details]
My xorg.conf file

From the directory: /etc/X11/
Comment 5 Sammy 2008-12-17 16:46:36 EST
Could this be related:

http://jeffreystedfast.blogspot.com/2008/07/more-pulseaudio-problems.html
Comment 6 Emanuele Bellini 2008-12-17 17:02:08 EST
(In reply to comment #5)
> Could this be related:
> 
> http://jeffreystedfast.blogspot.com/2008/07/more-pulseaudio-problems.html

Thank you, but this isn't the same problem at all: it isn't related to the audio, Gnome freezes whether I'm listening to music or not.
Comment 7 Emanuele Bellini 2008-12-17 17:12:02 EST
I had the freeze also going in another famous Italian web mail service (Alice Mail, but after the login). It means it's a problem I (and other people) could have with more than one website.
Moreover, I had no problem accessing this site with Fedora 9, nor accessing others. I have a working pair of old kernels registered in GRUB, to be sure I'm going to try to go to that website with FC9.
Comment 8 Emanuele Bellini 2008-12-18 16:50:38 EST
It does happen also with the older kernel

2.6.27.5-41.fc9.i686

it's only the kernel to be different, I ran on FC10 anyway.
Before I hadn't any kind of problem, so it might depend from the update to the 10th version of FC.
I have problems with the frame of Google Translate, too.
With Opera I can go on the pages that freeze using Firefox with no issues.
Comment 9 Emanuele Bellini 2008-12-26 13:57:21 EST
I've changed the severity because it happens with many sites! I must use Opera that doesn't always work (due to its low popularity), so sometimes I must use Firefox in Windows! Bill Gates laughs, he still can!
Comment 10 Emanuele Bellini 2008-12-29 08:38:24 EST
Finally, I've found the guilty: I'm sorry, I was forgetting I'm using the compositing manager in Metacity, in fact if I disable it, my computer doesn't freeze with the site above.
Maybe the Metacity compositor isn't popular enough, anyway I still don't know what to do when my computer locks up...
Comment 11 Matěj Cepl 2009-01-09 09:51:36 EST
(In reply to comment #10)
> Maybe the Metacity compositor isn't popular enough, anyway I still don't know
> what to do when my computer locks up...

Metacity compositor is a severe hack, which was never officially supported. I think if it doesn't work for you, the advice is simple -- don't use it.

Note You need to log in before you can comment on or make changes to this bug.