Bug 476669 - Shared child channels look really bad in Overveiw-> Org Trust view
Shared child channels look really bad in Overveiw-> Org Trust view
Status: CLOSED WONTFIX
Product: Spacewalk
Classification: Community
Component: WebUI (Show other bugs)
0.4
All Linux
low Severity medium
: ---
: ---
Assigned To: Jesus M. Rodriguez
wes hayutin
https://dhcp231-223.rdu.redhat.com/rh...
:
Depends On:
Blocks: space05
  Show dependency treegraph
 
Reported: 2008-12-16 10:09 EST by wes hayutin
Modified: 2009-03-11 15:35 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-10 22:22:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ss (308.63 KB, image/png)
2008-12-16 10:11 EST, wes hayutin
no flags Details

  None (edit)
Description wes hayutin 2008-12-16 10:09:57 EST
Description of problem:

recreate.
create a custom channel w/ the parent channel as a base channel
make the channel public

Navigate to Overview -> Org Trusts -> 
Channels Provided/ Channels Consumed

The channel is listed as 
Parent Channel Button  (no access to parent channel)  	  	
Child Channel westest 

see screenshot.  

We should figure out a better way to list the channel.
Maybe we can list the name, and add (no access)
Comment 1 wes hayutin 2008-12-16 10:11:54 EST
Created attachment 327113 [details]
ss
Comment 2 Shannon Hughes 2009-01-07 11:02:44 EST
this would be a global change to all the channel lists and estimating about 6 hours effort. moving this to low priority since current functionality works and this is a question of appearance. the one downside to this request is it does create a data leakage for the parent channel name. probably not a big security concern but worth mentioning since a parent name could have release/version info in the name that should not be shared out.
Comment 3 Jesus M. Rodriguez 2009-01-09 16:23:35 EST
Moving to space05. Like shughes said, this is not a localized issue and requires a more broad view of the UI. Adding mizmo on the Cc and NEEDINFO for a proposed better way. 

I'm ok with putting in the name followed by (no access). But usually the reason we don't list the name is you don't have access to it so you don't get to see anything about it, including the name.
Comment 4 Máirín Duffy 2009-01-12 11:08:23 EST
I don't think putting the name is a good idea because there may be information in the name that is not public. (E.g., think of the ISP Satellite usecase: the parent channel name might have the name of another customer on the Satellite. This kind of information leakage is bad.)

The channel can't be consumed if you can't access its parent can it?
Comment 5 wes hayutin 2009-02-23 15:59:23 EST
Child channels can... be consumed even if the org does NOT have rights to the parent.

created that scenario on the latest build
Comment 6 Jesus M. Rodriguez 2009-03-10 22:22:31 EDT
If we can't show the user the base channel name, there is really no other 
thing to show other than 'no access to parent' which is pretty much self explanatory.

I'm going to close this as WONTFIX.
Comment 7 Máirín Duffy 2009-03-11 15:35:57 EDT
Jesus, you can't say WHY there is no access? 

eg

"<em>Parent channel inaccessible. Insufficient entitlements. For access, contact your organization administrator</em>"
"<em>Parent channel inaccessible. Insufficient permissions. For access, contact your organization administrator.</em>"

Explain the problem clearly and give some pointers as to how to fix it.

Note You need to log in before you can comment on or make changes to this bug.