Bug 476690 - HTS-5.3-9 Profiler Test Fails [NEEDINFO]
HTS-5.3-9 Profiler Test Fails
Status: CLOSED ERRATA
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests) (Show other bugs)
5.3
All Linux
low Severity high
: ---
: ---
Assigned To: Rob Landry
Lawrence Lim
: Documentation, Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-16 10:51 EST by Mark Coskey
Modified: 2014-03-25 20:55 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: ====== The PROFILER test fails for "no sample file found". Consequence: ============ The PROFILER test could not pass. Fix: ==== Add the check for Timer configuration. Result: ======= The PROFILER test works well now.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-27 12:35:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rlandry: needinfo? (mark.coskey)


Attachments (Terms of Use)
HTS results package (1.55 MB, application/octet-stream)
2008-12-16 10:54 EST, Mark Coskey
no flags Details
failed profiler on amd (837 bytes, application/octet-stream)
2009-01-13 10:59 EST, Gregg Shick
no flags Details
5.3-12 passing output on intel box (1.04 KB, application/octet-stream)
2009-01-13 10:59 EST, Gregg Shick
no flags Details

  None (edit)
Description Mark Coskey 2008-12-16 10:51:35 EST
Description of problem:
Using HTS-5.3-9 the profiler test fails for "no sample file found".  The HTS documenatation at /var/hts/docs does not list this test so I don't know what sample file it needs.

Version-Release number of selected component (if applicable): HTS-5.3-9


How reproducible: Profiler always fails


Steps to Reproduce:
1. Install RHEL5.3
2. Install HTS-5.3-9
3. Launch profiler test
  
Actual results: Profiler test fails b/c no sample file was found.


Expected results: Profiler test should pass.


Additional info: See attached results package.  Tested on the BL495cG5 with RHEL5.3x86 snapshot 5.
Comment 1 Mark Coskey 2008-12-16 10:54:14 EST
Created attachment 327117 [details]
HTS results package
Comment 2 Rob Landry 2008-12-16 18:47:22 EST
Looks like there some bogus output from opcontrol...

/usr/bin/opcontrol: line 1118: echo: write error: Invalid argument

...which we'll need to check into to see if it's a bug in hts or oprofile or whatever. In addition please add "options oprofile timer=1" to modprobe.conf and rerun the oprofiler test.  This may work around the profile test failure, but it looks like oprofile was trying to use the more exact hardware modes but failed to do so.
Comment 3 Gregg Shick 2009-01-13 10:59:24 EST
Created attachment 328877 [details]
failed profiler on amd
Comment 4 Gregg Shick 2009-01-13 10:59:48 EST
Created attachment 328879 [details]
5.3-12 passing output on intel box
Comment 5 Gregg Shick 2009-01-13 11:00:23 EST
comment 3 was run with 5.3-12.
Comment 6 Rob Landry 2009-01-19 11:16:36 EST
Hi Gregg,

Can you try adding...

options oprofile timer=1

...to modprobe.conf on the AMD box and rerun the test?  You may also need to verify that oprofile isn't already loaded before running the test again to ensure the option takes effect.

...or was that already done in these later runs?
Comment 7 Quang Duong 2009-01-20 14:09:57 EST
Profiler passed on AMD box using this command (was run with hts5.3-12)

Quang
Comment 8 Rob Landry 2009-02-25 16:23:25 EST
Is this still a problem or does the timer mode and/or hts-5.3-15 resolve this issue?
Comment 9 Rob Landry 2009-05-12 11:49:19 EDT
I'm going to go ahead and close this presuming either the later hts package or the timer mode resolves the issue.
Comment 10 Gregg Shick 2009-05-12 11:51:42 EDT
Rob

5.3-15 did not resolve this issue. We are still using the workaround.  Do you have a later hts to try?
Comment 11 Rob Landry 2009-05-12 12:02:44 EDT
Hi Gregg, workaround meaning timer mode or something else?  There is an hts-5.3-17 in RHN now, though I don't think there are any profiler test fixes in it.
Comment 12 Gregg Shick 2009-05-12 12:10:38 EDT
Rob

Yep the timer mode change:

1.  Open modprobe.conf
2.  Add "options oprofile timer=1" 

We still have to do it with -15.
Comment 13 Rob Landry 2009-05-12 12:41:37 EDT
Gregg,

The -xen kernel should default to the timer mode, also unrecognised processors by oprofile should default to timer mode.  Is the same behavior noted when using the BM kernel and is this on all system or  specific one with a specific processor?
Comment 15 Gregg Shick 2009-05-13 11:57:25 EDT
Rob

We saw it mostly on AMD procs, but also some Intels.  I don't have a more recent list since we have gone to making sure that line is present but we will start running profiler without any manually edits first to identify the procs.
Comment 24 Rob Landry 2009-06-18 18:57:08 EDT
Hey Greg,

v7-1.0-6 includes a patch to automatically add the timer=1 option as required which should hopefully avoid the need to manually provide it. 

From what we've been able to determine there's an issue with oprofile version included in RHEL4 where it and the nmiwatchdog will have a resource collision if the specific hardware does not include dedicated support in oprofiler; specifically where opofiler tries to fall back to the nmitimer which is already claimed by the nmiwatchdog; this seems to be the root cause for the many cases of RHEL4 needing the timer=1 option, as this falls back even farther into a software timer operation.
Comment 26 Yan Tian 2009-08-13 04:49:40 EDT
Verified v7-1.0-14.el5 profiler test passed on RHEL5.4 Server x86_64 system.
Comment 29 YangKun 2009-08-21 02:04:41 EDT
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

New Contents:
Cause:
======
The PROFILER test fails for "no sample file found".

Consequence:
============
The PROFILER test could not pass.

Fix:
====
Add the check for Timer configuration.

Result:
=======
The PROFILER test works well now.
Comment 30 errata-xmlrpc 2009-08-27 12:35:42 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1234.html

Note You need to log in before you can comment on or make changes to this bug.