Bug 4767 - splitting mod_php3 packages caused configure problems
splitting mod_php3 packages caused configure problems
Status: CLOSED CURRENTRELEASE
Product: Red Hat Raw Hide
Classification: Retired
Component: mod_php3 (Show other bugs)
1.0
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Preston Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-08-28 17:59 EDT by Jay Freeman
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-09-23 20:17:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jay Freeman 1999-08-28 17:59:01 EDT
If you do a   configure --with-pgsql   you normally see
this:

checking for PostgresSQL support... yes
checking for PQcmdTuples... yes

:which detects cmdTuples, and defines HAVE_PGCMDTUPLES,
however since mod_php3 is no longer being compiled with
built in pgsql support, that is no longer being passed to
configure, and the resulting module doesn't contain this
support.  You should be able to simply -D this into the gcc
statement that compiles the pgsql support, but a better
option might be to redo the configure statement before
compiling each module, and include the required --with (or
just do this once after compiling the main php3 module with
the --with for ALL the later compiled modules).  That way
any new configuration options that are needed by the
modules will be compiled in as the PHP people add them.
Comment 1 Preston Brown 1999-08-29 12:05:59 EDT
this has been fixed for the next release (6.1) in php-3.0.12-3 and
later.
Comment 2 Jay Freeman 1999-09-04 16:20:59 EDT
php-3.0.12-4 still does not include pg_cmdtuples() support
Comment 3 Jay Freeman 1999-09-04 17:04:59 EDT
Sorry, this is probably my fault.  I stated that the correct define
was HAVE_PGCMDTUPLES, when it is really HAVE_PQCMDTUPLES, with a Q
instead of the G.  This affects the following line in the spec file:

gcc -shared -fPIC -DCOMPILE_DL=1 -DHAVE_PGCMDTUPLES -I. -
I/usr/include/apache \
        -I/usr/include/pgsql -o pgsql.so \
        ./functions/pgsql.c -lpq -lc
Comment 4 Preston Brown 1999-09-23 20:17:59 EDT
fixed in the 3.0.12-5 build.

Note You need to log in before you can comment on or make changes to this bug.