Bug 476712 - Package Review: lua-rex - Regular expression handling library for Lua
Package Review: lua-rex - Regular expression handling library for Lua
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-16 12:27 EST by Lubomir Rintel
Modified: 2013-01-09 23:58 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-05 19:11:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
jkeating: fedora‑review+
kevin: fedora‑cvs+


Attachments (Terms of Use)

  None (edit)
Description Lubomir Rintel 2008-12-16 12:27:48 EST
SPEC: http://netbsd.sk/~lkundrak/SPECS/lua-rex.spec
SRPM: http://netbsd.sk/~lkundrak/SRPMS/lua-rex-2.4.0-1.fc10.src.rpm

Description:

Lrexlib are bindings of three regular expression library APIs (POSIX, PCRE
and Oniguruma) to Lua.
Comment 1 Lubomir Rintel 2008-12-16 12:30:59 EST
Builds in fedora-10-i386 mock, rpmlint silent and happy.
Comment 2 Jesse Keating 2008-12-16 18:26:09 EST
Taking review.
Comment 3 Jesse Keating 2008-12-16 18:38:31 EST
Should the .so files go in a -devel subpackage?

License seems good

Why isn't doc/ packaged in %doc ?

Why aren't smp_flags used?

What is the purpose of the manual lrexlib Provides?  What will be Requiring that, other than the other auto-generated Provides:

rex_onig.so.2.4  
rex_pcre.so.2.4  
rex_posix.so.2.4  
lua-rex = 2.4.0-1.fc11
lua-rex(x86-32) = 2.4.0-1.fc11
Comment 4 Lubomir Rintel 2008-12-17 07:04:14 EST
(In reply to comment #3)
> Should the .so files go in a -devel subpackage?

No. They are not meant for use by linker, lua interpreter looks for .so files specifically.

I'm thinking whether it makes sense to ship the .2.4 files, but it's that just because upstream does so. The .so files don't have a SONAME and are not used by dynamic linker, just dlopened by lua.

> License seems good
> 
> Why isn't doc/ packaged in %doc ?

I just forgot. I'll be including it in new package I'll post shortly.

> Why aren't smp_flags used?

There's a comment. Or should I be more specific than just "doesn't work"?

> What is the purpose of the manual lrexlib Provides?  What will be Requiring
> that, other than the other auto-generated Provides:
> 
> rex_onig.so.2.4  
> rex_pcre.so.2.4  
> rex_posix.so.2.4  
> lua-rex = 2.4.0-1.fc11
> lua-rex(x86-32) = 2.4.0-1.fc11

That's an upstream name. While it is desirable to name this package lua-rex, to denote it's a lua rex module there's a chance people will try to install it by doing "yum install lrexlib". If I remember correctly this is a recommended practice for perl modules, and I assumed it would be the same for lua.
Comment 5 Lubomir Rintel 2008-12-17 13:18:50 EST
SPEC: http://netbsd.sk/~lkundrak/SPECS/lua-rex.spec
SRPM: http://netbsd.sk/~lkundrak/SRPMS/lua-rex-2.4.0-2.el5.src.rpm

* Wed Dec 17 2008 Lubomir Rintel <lkundrak@v3.sk> - 2.4.0-2
- Add doc directory to documentation
- Allow parallel make runs
Comment 6 Jesse Keating 2008-12-17 16:47:56 EST
Looks great now, approving.

At some point you should probably bring a lua packaging guideline suggestion to the FPC since there are a few lua packages in now, and could be more coming.  It'd speed up reviews.
Comment 7 Lubomir Rintel 2008-12-18 02:11:55 EST
New Package CVS Request
=======================
Package Name: lua-rex
Short Description: Regular expression handling library for Lua
Owners: lkundrak
Branches: F-10
Comment 8 Kevin Fenzi 2008-12-20 23:43:26 EST
cvs done.

Note You need to log in before you can comment on or make changes to this bug.