Bug 476724 - setting font rendering to monochrome results in redacted text :-)
setting font rendering to monochrome results in redacted text :-)
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nv (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-16 14:09 EST by Tom Horsley
Modified: 2009-01-16 17:52 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-16 17:52:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gnome-apperence-properties screen shot (37.80 KB, image/png)
2008-12-16 14:11 EST, Tom Horsley
no flags Details

  None (edit)
Description Tom Horsley 2008-12-16 14:09:43 EST
Description of problem:

If I go to the "Fonts" panel in gnome-appearance-properties and click
on the "Monochrome" radio button, font rendering goes totally wacky,
as though a black marker has been used to overwrite lines of text at
random. (I'll attach a screen shot of gnome-appearence-properties
itself for you to marvel at).

Version-Release number of selected component (if applicable):
gtk2-2.14.4-3.fc10.i386

How reproducible:
every time

Steps to Reproduce:
1. see above
2.
3.
  
Actual results:
blacked out text

Expected results:
monochrome text without the annoying color fringes.

Additional info:
No doubt this could be a problem with the fonts themselves or the video driver
of something else, but I start with gtk as the best guess. I'm using older
nvidia driver in case that is relevant:

kmod-nvidia-96xx-2.6.27.7-134.fc10.i686-96.43.09-1.fc10.7.i686
Comment 1 Tom Horsley 2008-12-16 14:11:05 EST
Created attachment 327149 [details]
gnome-apperence-properties screen shot
Comment 2 Tom Horsley 2008-12-17 18:18:51 EST
I tried this on a different machine with different video driver,
and the blacked out text didn't happen, if anything the result
was almost the opposite with text going all thin and spidery as
if a one pixel wide pen was used to draw the glyphs.

I also tried picking different fonts in firefox on the original
machine, and I can dramatically reduce the color fringes with
other fonts even without setting the monochrome option, so that's
what I've done for now.
Comment 3 Tom Horsley 2008-12-18 15:33:17 EST
This definitely has something to do with the video driver (though I have
no idea if it is strictly a bug in the driver or merely some strange
interaction).

I changed the driver from the nvidia-96xx version to the nvidia-173xx
version, and the blacked out text when picking monochrome did not happen,
just the same spidery text as the other machine.
Comment 4 Matěj Cepl 2009-01-16 17:52:27 EST
Thanks for the report. We are sorry that we cannot help you with your problem, but we are not able to support binary-only drivers. If you would be able to reproduce this issue using only open source software (xorg-x11-drv-nv or xorg-x11-drv-nouveau, if that works for you), please, reopen this bug with the additional information, but in meantime I have no choice than to close this bug as CANTFIX (because we really cannot fix it).

For users who are experiencing problems installing, configuring, or using the unsupported 3rd party proprietary "nvidia" video driver, Nvidia provides indirect customer support via an online web based support forum.  Nvidia monitors these web forums for commonly reported problems and passes them on to Nvidia engineers for investigation.  Once they've isolated a particular problem, it is often fixed in a future video driver update.

The NVNews Nvidia Linux driver forum is located at:

    http://www.nvnews.net/vbulletin/forumdisplay.php?s=&forumid=14

Once you have reported this issue in the Nvidia web forums, others who may have experienced the particular problem may be able to assist.  If there is a real bug occuring, Nvidia will be able to determine this, and will likely resolve the issue in a future driver update for the operating system releases that they officially support.

While Red Hat does not support the proprietary nvidia driver, users requiring technical support may also find the various X.Org, XFree86, and Red Hat mailing lists helpful in finding assistance:

X.Org mailing lists:
    http://www.freedesktop.org/XOrg/XorgMailingLists

XFree86 mailing lists:
    http://www.xfree86.org/sos/lists.html

Red Hat mailing lists:
    https://listman.redhat.com/mailman/listinfo

Note You need to log in before you can comment on or make changes to this bug.