Bug 476740 - Exception in packages.py line 981 in __init__ (F10-x86_64)
Exception in packages.py line 981 in __init__ (F10-x86_64)
Status: CLOSED DUPLICATE of bug 473239
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
10
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-16 16:05 EST by Jeff Randall
Modified: 2014-01-21 18:07 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-16 17:03:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda exception (62.10 KB, text/plain)
2008-12-16 16:05 EST, Jeff Randall
no flags Details

  None (edit)
Description Jeff Randall 2008-12-16 16:05:11 EST
Created attachment 327164 [details]
Anaconda exception

Description of problem:
Exception in anaconda when trying to upgrade or install on a Dell Vostro 400.
packages.py line 981 in __init__ is trying to call replace on a list and the version of python being used complains that this is not a valid operation and throws the exception.


Version-Release number of selected component (if applicable):


How reproducible:
Every time.


Steps to Reproduce:
1. Attempt to install or upgrade.
2.
3.
  

Actual results:
Exception during dependency checking and install/upgrade fails.

Expected results:
Dependency checking to complete and installation to continue.


Additional info:
Machine is a Dell Vostro 400 that has been happily running F8-x86_64 for a year and was able to be upgraded to f9-x86_64 without issue.

Have seen the same exception when attempting:
 - upgrade via DVD from F8-x86_64 to F10-x86_64 
 - upgrade via DVD from F9-x86_64 to F10-x86_64
 - install F10-x86_64 via DVD
 - upgrade F9-x86_64 via the preupgrade program.
Comment 1 seth vidal 2008-12-16 17:03:29 EST

*** This bug has been marked as a duplicate of bug 473239 ***

Note You need to log in before you can comment on or make changes to this bug.