Bug 476759 - QMF Agent stops publishing after running for a time
QMF Agent stops publishing after running for a time
Status: CLOSED ERRATA
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-qmf (Show other bugs)
1.1
All Linux
high Severity high
: 1.1.1
: ---
Assigned To: Ted Ross
Jan Sarenik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-16 18:19 EST by Ted Ross
Modified: 2011-08-12 12:04 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-21 12:18:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ted Ross 2008-12-16 18:19:13 EST
It was noticed that all of the sesame (system agent) processes running in the North grid test environment were not publishing updates.  If qpid-tool is run against the broker (North-15), no sysimage objects are seen even though there are several sesame daemons running.

The pstacks of some of the sesame processes were observed and found to be in normal "idle" state.  More investigation is needed.
Comment 1 Ted Ross 2008-12-17 14:37:13 EST
A potential workaround has been committed upstream at revision 727485.

This won't solve the root problem, but if the qmf-agent session is lost for any reason, this change will cycle the connection for a fresh start.  It will also log the exception that caused the problem to begin with.

I am bumping the target to 1.1.1 and not setting to MODIFIED in hopes that more information will emerge leading to a solution to the root cause.
Comment 2 Ted Ross 2008-12-18 15:44:22 EST
BZ 477036 is likely related to this bug.  I think that the symptom described in that bug is the cause for session loss in the qmf agents.

In other words, messages sent from an agent to the "qpid.management" topic exchange are dropped with a session-ending exception when there is a backed-up queue bound to the exchange.
Comment 3 Ted Ross 2009-01-15 11:59:22 EST
The committed workaround appears to have solved the problem.
Comment 5 Jan Sarenik 2009-04-01 05:01:58 EDT
Not reproducable on old version.

After creating a queue bound to exchange qpid.management
and filling it up to its limit, the connection to e.g. cumin
is not lost and I do not see any Exception in the logs.

Issue not seen on current errata versions of
  qpidd-0.5.752581-3.el5
  qmf-0.5.752581-3.el5
Comment 7 errata-xmlrpc 2009-04-21 12:18:25 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-0434.html

Note You need to log in before you can comment on or make changes to this bug.