Bug 476787 - unpacking of archive failed on file /usr/lib/atlas: cpio: rename
unpacking of archive failed on file /usr/lib/atlas: cpio: rename
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: atlas (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Deji Akingunola
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-16 23:52 EST by Mamoru TASAKA
Modified: 2008-12-20 23:06 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-20 23:06:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mamoru TASAKA 2008-12-16 23:52:43 EST
Description of problem:
[root@localhost i386]# rpm -q atlas
atlas-3.6.0-15.fc10.i386

[root@localhost i386]# LANG=C yum -y upgrade --exclude=........
Excluding Packages in global exclude list
Finished
Setting up Upgrade Process
Resolving Dependencies
--> Running transaction check
---> Package atlas-sse2.i386 0:3.8.2-2.fc11 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

=================================================================================================================================
 Package                         Arch                      Version                            Repository                    Size
=================================================================================================================================
Installing:
 atlas-sse2                      i386                      3.8.2-2.fc11                       koji-11                      2.8 M
     replacing  atlas.i386 3.6.0-15.fc10


Transaction Summary
=================================================================================================================================
Install      1 Package(s)         
Update       0 Package(s)         
Remove       0 Package(s)         

Total size: 2.8 M
Downloading Packages:
======================================================= Entering rpm code =======================================================
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing     : atlas-sse2                                                                                                1/2 
Error unpacking rpm package atlas-sse2-3.8.2-2.fc11.i386
error: unpacking of archive failed on file /usr/lib/atlas: cpio: rename
======================================================= Leaving rpm code ========================================================

Installed:
  atlas-sse2.i386 0:3.8.2-2.fc11                                                                                                 

Replaced:
  atlas.i386 0:3.6.0-15.fc10                                                                                                     

Complete!

Well, actually not complete...
The problem is that in atlas-3.6.0-15.fc10 /usr/lib/atlas was actually
a directory. Then atlas-sse2-3.8.2-{2,3}.fc11 tries to replace this
_directory_ with _symlink_, this cannot be done with rpm.

Version-Release number of selected component (if applicable):
atlas-3.8.2-3.fc11

How reproducible:
100%

Steps to Reproduce:
1. yum -y upgrade
2. see what happens on atlas
3.
  
Actual results:
see above
Comment 1 Deji Akingunola 2008-12-17 00:26:19 EST
Thanks for the report. I will change the linking directory together to actually copying /usr/lib/atlas-sse2 into /usr/lib/atlas.
Comment 2 Deji Akingunola 2008-12-20 23:06:08 EST
I believe you are OK with the above changes. If not, please reopen the bug.

Note You need to log in before you can comment on or make changes to this bug.