Bug 476837 - RFE: add option to not umount tmpfs only for clean
RFE: add option to not umount tmpfs only for clean
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mock (Show other bugs)
19
All Linux
low Severity medium
: ---
: ---
Assigned To: Clark Williams
Fedora Extras Quality Assurance
FutureFeature
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-17 08:30 EST by Till Maas
Modified: 2015-06-01 08:10 EDT (History)
8 users (show)

See Also:
Fixed In Version: mock-1.2.3-1.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-12-11 23:07:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
tmpfs keep_mounted option (3.16 KB, patch)
2014-11-24 05:59 EST, Mikhail Campos
no flags Details | Diff

  None (edit)
Description Till Maas 2008-12-17 08:30:03 EST
I would like to use tmpfs with mock, but I want still access to the buildroot after a successful build. Therefore I would like to have an option to make mock do this:

1) Always mount tmpfs without -n to make it easier to determine, whether it is already mounted
2) Umount the tmpfs in clean state if it is mounted
3) Do not umount it in other states

Everyone who still wants the tmpfs to be umounted can run mock with "--cleanup-after" and afaics will see no difference, because umounting the tmpfs has the same effect.
Comment 1 Miroslav Suchý 2014-11-18 11:10:22 EST
Fedorahosted product is retired and nearly invisible. Moving to Fedora product.
Comment 2 Mikhail Campos 2014-11-24 05:59:26 EST
Created attachment 960655 [details]
tmpfs keep_mounted option

Patch attached. 

If used, then tmpfs can be manually unmounted by clean/scrub/cleanup-after (tmpfs plugin MUST be enabled). 
Also, I think, that should be disabled by default because if used by none-experienced users, can cause additional mock usage problems (example: tmpfs not unmounted + plugin disabled + mock --clean -> "resource busy" error)
Comment 3 Miroslav Suchý 2014-11-24 07:28:01 EST
Commited as c0bef2a

And I add check if keep_mounted key is present in commit 7ab37b8

Thanks for contribution.
Comment 4 Mikhail Campos 2014-11-25 05:00:03 EST
Thank you for review
Comment 5 Fedora Update System 2014-12-04 07:06:29 EST
mock-1.2.3-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/mock-1.2.3-1.fc21
Comment 6 Fedora Update System 2014-12-04 07:10:00 EST
mock-1.2.3-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/mock-1.2.3-1.fc20
Comment 7 Fedora Update System 2014-12-04 07:10:57 EST
mock-1.2.3-1.el7 has been submitted as an update for Fedora EPEL 7.
https://admin.fedoraproject.org/updates/mock-1.2.3-1.el7
Comment 8 Fedora Update System 2014-12-04 07:12:25 EST
mock-1.2.3-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/mock-1.2.3-1.el6
Comment 9 Fedora Update System 2014-12-04 19:46:39 EST
Package mock-1.2.3-1.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing mock-1.2.3-1.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-16285/mock-1.2.3-1.fc21
then log in and leave karma (feedback).
Comment 10 Fedora Update System 2014-12-11 23:07:22 EST
mock-1.2.3-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2014-12-16 23:42:27 EST
mock-1.2.3-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2015-01-05 21:06:10 EST
mock-1.2.3-1.el7 has been pushed to the Fedora EPEL 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2015-01-05 21:07:35 EST
mock-1.2.3-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.