Bug 476840 - ds9 will not start due to missing package base64 not installed with dependancies
ds9 will not start due to missing package base64 not installed with dependancies
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: ds9 (Show other bugs)
10
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Sergio Pascual
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-17 08:46 EST by Anthony Horton
Modified: 2009-01-07 04:22 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-07 04:22:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Transcript of installation and startup attempt (9.26 KB, text/plain)
2008-12-17 09:26 EST, Anthony Horton
no flags Details

  None (edit)
Description Anthony Horton 2008-12-17 08:46:56 EST
Description of problem:

I installed ds9 and funtools from the Fedora 10 yum repositories but when I try to run ds9 it fails with the message: 

Error in startup script: can't find package base64 while executing "package require base64"

Version-Release number of selected component (if applicable):

ds9.i386 0:5.4-1.fc10

How reproducible:

Always.

Steps to Reproduce:
1. Install ds9 from the Fedora 10 repositories
2. Try to run it.
  
Actual results:

An error about a missing package base64.

Expected results:

ds9 starting.

Additional info:

It looks like the startupp script for the i386 ds9 package is looking for a component of the x86_64 version.

Transcript of the installation and error message attached.
Comment 1 Sergio Pascual 2008-12-17 08:56:02 EST
The missing package is tcllib. Somehow I missed it in the dependencies. As a workaround please do 
# yum install tcllib 
after installing ds9
Comment 2 Anthony Horton 2008-12-17 09:26:42 EST
Created attachment 327249 [details]
Transcript of installation and startup attempt
Comment 3 Anthony Horton 2008-12-17 09:47:12 EST
Wow, fast response!  Thanks, installing tcllib fixed it.
Comment 4 Fedora Update System 2008-12-17 11:17:59 EST
ds9-5.4-2.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/ds9-5.4-2.fc10
Comment 5 Fedora Update System 2008-12-21 03:30:53 EST
ds9-5.4-2.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing-newkey update ds9'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-11580
Comment 6 Fedora Update System 2008-12-21 03:33:06 EST
ds9-5.4-2.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ds9'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2008-11555
Comment 7 Fedora Update System 2009-01-07 04:18:42 EST
ds9-5.4-2.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2009-01-07 04:22:56 EST
ds9-5.4-2.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.