Bug 476845 - oocalc hang
oocalc hang
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-17 09:24 EST by Horst H. von Brand
Modified: 2009-03-05 05:24 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-05 05:24:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Horst H. von Brand 2008-12-17 09:24:24 EST
Description of problem:
Trying to set language settings (Tools -> Options -> Language Settings -> Language), when giving OK oocalc hang completely. The window borders became dark gray, had to force quit. CPU Frequency Scaling Monitor showed both cores at 100% (usually it is 44%). I had an .ods, a .doc, and an .xls open at the time.
After recovery, the settings are as I wanted to set them.

Version-Release number of selected component (if applicable):
openoffice.org-calc-3.0.1-13.2.fc11.x86_64

How reproducible:
Happened once.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Caolan McNamara 2008-12-17 10:36:43 EST
Was there any specific language setting involved ?
Comment 2 Horst H. von Brand 2008-12-17 11:45:08 EST
Sorry, forgot that detail.

I had set a few cells to currency format in the .ods, and had to set the language from "Default" to "Spanish (Chile)". To avoid this in the future I went to set the language default to "Spanish (Chile)". I had also futzed around with Tools -> Options -> OpenOffice.org -> User data, and had saved those changes without trouble.
Comment 3 Caolan McNamara 2009-01-13 07:15:05 EST
I can't make it hang for me. Are you able to get this to happen again from scratch ?
Comment 4 Antonio A. Olivares 2009-01-30 11:23:24 EST
I am having a similar problem.  I open a *.odt or a Word File, I choose File --> Save As and OpenOffice writer hangs :(, only option is to force quit.  I try to export to PDF and same thing happens.  Upon restarting OpenOffice writer gives me the option to do a recovery for the file which I was working on/(trying to save as or export to PDF).  Instead of opening a new bug(might get a duplicate), I add my comments to this one.  different platform though. not x86_64

[olivares@localhost ~]$ rpm -qa openoffice*
openoffice.org-fonts-3.0.1-15.1.fc11.i386
openoffice.org-calc-core-3.0.1-15.5.fc11.i386
openoffice.org-xsltfilter-3.0.1-15.5.fc11.i386
openoffice.org-draw-core-3.0.1-15.5.fc11.i386
openoffice.org-graphicfilter-3.0.1-15.5.fc11.i386
openoffice.org-writer-core-3.0.1-15.5.fc11.i386
openoffice.org-base-core-3.0.1-15.5.fc11.i386
openoffice.org-impress-core-3.0.1-15.5.fc11.i386
openoffice.org-calc-3.0.1-15.5.fc11.i386
openoffice.org-pdfimport-3.0.1-15.5.fc11.i386
openoffice.org-opensymbol-fonts-3.0.1-15.5.fc11.i386
openoffice.org-presenter-screen-3.0.1-15.5.fc11.i386
openoffice.org-draw-3.0.1-15.5.fc11.i386
openoffice.org-brand-3.0.1-15.5.fc11.i386
openoffice.org-writer-3.0.1-15.5.fc11.i386
openoffice.org-langpack-es-3.0.1-15.5.fc11.i386
openoffice.org-impress-3.0.1-15.5.fc11.i386
openoffice.org-math-core-3.0.1-15.5.fc11.i386
openoffice.org-core-3.0.1-15.5.fc11.i386
openoffice.org-math-3.0.1-15.5.fc11.i386
openoffice.org-writer2latex-0.5.0.2-4.fc11.i386
openoffice.org-ure-3.0.1-15.5.fc11.i386
[olivares@localhost ~]$ uname -a
Linux localhost 2.6.29-0.66.rc3.fc11.i686 #1 SMP Thu Jan 29 14:58:12 EST 2009 i686 athlon i386 GNU/Linux
[olivares@localhost ~]$
Comment 5 antonio montagnani 2009-01-30 11:46:49 EST
I confirm, same problem with i386 platform and older kernel :-(
Comment 6 Caolan McNamara 2009-01-30 11:50:31 EST
I open a *.odt or a Word File, I choose File--> Save As and OpenOffice writer hangs :("

That is definitely bug 477174 

This one is apparently different, it might be that the original hang happened on a gtk dialog in which case this becomes a duplicate of bug 477174, but the suggestion is that futzing with currency/language settings causes a hang
Comment 7 Caolan McNamara 2009-03-05 05:24:44 EST
The libX11 bug is fixed, so if it was that then its fixed. 

Otherwise I reworked the "set language from locale" stuff so if it was related to that original hackery, it should be gone as well.

Here's hoping...

Note You need to log in before you can comment on or make changes to this bug.