Bug 476853 - OpenJDK .desktop files use non-standard categories, which affects availability of menu launchers
OpenJDK .desktop files use non-standard categories, which affects availabilit...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: java-1.6.0-openjdk (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Deepak Bhole
BaseOS QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-17 09:54 EST by Radek Bíba
Modified: 2010-04-08 07:01 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-08 07:01:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Radek Bíba 2008-12-17 09:54:37 EST
Description of problem:
/usr/share/applications/java-1.6.0-openjdk-policytool.desktop contains Categories=Java and java-1.6.0-openjdk-jconsole.desktop contains Monitor;Java. This makes KDE place launch files for the target utilities into Lost & Found in the K menu, and the Gnome menu apparently ignores these desktop files completely because I can't find the launchers anywhere in the menu. Could we use some standard categories?

Version-Release number of selected component (if applicable):
java-1.6.0-openjdk-1.6.0.0-0.25.b09.el5
Comment 1 RHEL Product and Program Management 2009-11-06 14:20:18 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 2 Radek Bíba 2010-04-08 07:01:55 EDT
Alright, this is (silently) fixed in java-1.6.0-openjdk-1.6.0.0-1.11.b16.el5, the latest errata package. There are menu items for these two utilities now, both in Gnome and in KDE. However, it turns out that clicking them doesn't necessarily launch the desired applications. I'll file a new bug for that.

Note You need to log in before you can comment on or make changes to this bug.