Bug 476877 - Curious (and intermittent) not-attached error from failover listener
Curious (and intermittent) not-attached error from failover listener
Status: CLOSED NOTABUG
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp (Show other bugs)
1.1
All Linux
low Severity low
: ---
: ---
Assigned To: messaging-bugs
Frantisek Reznicek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-17 12:20 EST by Gordon Sim
Modified: 2015-11-15 19:06 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-16 12:50:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gordon Sim 2008-12-17 12:20:07 EST
When running perftest in a loop against a one node cluster (I used --count 1000 --size 8), an not-attached error is periodically logged by the failover listener. Test appears to work fine  otherwise.

20371.2 6905.89 18483.3 0.141016
15180.3 5655.28 11492   0.0876771
21542.4 7300.5  17744.8 0.135382
17133   8863.52 16514.7 0.125997
2008-dec-17 17:22:57 error amq.failover87113fec-7a83-45ba-b25f-6af88fbf7552@guest error: not-attached: Session amq.failover87113fec-7a83-45ba-b25f-6af88fbf7552@guest isn't attached (qpid/client/SessionImpl.cpp:659)
2008-dec-17 17:22:57 error not-attached: Session amq.failover87113fec-7a83-45ba-b25f-6af88fbf7552@guest isn't attached (qpid/client/SessionImpl.cpp:659) (qpid/client/FailoverListener.cpp:73)
9852.51 7559.49 16940.4 0.129245
15919.5 7056.07 16044.2 0.122407
9015.1  6730.79 15498.7 0.118246
12592.2 7947.36 18777.9 0.143264
Comment 1 Gordon Sim 2008-12-17 13:03:43 EST
I can't reproduce this on mrg15 (just on my laptop so far) so I'm lowering the priority even more and removing it from the 1.1 set. May not be a real issue.

Note You need to log in before you can comment on or make changes to this bug.