Bug 476878 - bochs-dlxlinux RPM ships pre-built disk-image of linux kernel + shell tools with no source code
bochs-dlxlinux RPM ships pre-built disk-image of linux kernel + shell tools w...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: bochs (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
:
Depends On:
Blocks: FE-Legal
  Show dependency treegraph
 
Reported: 2008-12-17 12:22 EST by Daniel Berrange
Modified: 2008-12-18 06:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-18 06:12:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Daniel Berrange 2008-12-17 12:22:09 EST
Description of problem:
The bochs-dlxlinux RPM contains a file

/usr/share/bochs/dlxlinux/hd10meg.img.gz

which is a bootable disk image containing Linux (ancient 1.3.89 !) and a collection of userspace tools (grep, awk, tar, etc, etc). 

There does not appear to be any source for for these binaries. CVS appears to get them pre-built from the file dlxlinux4.tar.gz, again with no source present. The website listed in the README of dlxlinux4.tar.gz does not appear to exist anymore.

This all seems questionable from a license compliance point of view.

Version-Release number of selected component (if applicable):
bochs-dlxlinux-2.3.6-3.fc9.i386.rpm

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Tom "spot" Callaway 2008-12-17 12:32:15 EST
Is this useful? I think this needs to go.
Comment 2 Hans de Goede 2008-12-18 06:12:38 EST
Ok, since this is obviously a licensing problem, and since there is no way to fix this I've removed the dlxlinux subpackage.

Note You need to log in before you can comment on or make changes to this bug.