Bug 476884 - publican User Guide unreadable because sidebar obscures text
publican User Guide unreadable because sidebar obscures text
Status: CLOSED CURRENTRELEASE
Product: Publican
Classification: Community
Component: publican (Show other bugs)
1.6
All Linux
low Severity medium
: ---
: ---
Assigned To: Jeff Fearn
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-17 13:31 EST by John Ellson
Modified: 2010-11-23 23:17 EST (History)
3 users (show)

See Also:
Fixed In Version: 0.40
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-06 01:42:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
screen-grab of the problem (287.29 KB, image/png)
2008-12-17 13:31 EST, John Ellson
no flags Details

  None (edit)
Description John Ellson 2008-12-17 13:31:08 EST
Created attachment 327272 [details]
screen-grab of the problem

Description of problem:
The User Guide (file:///usr/share/doc/publican-doc-0.39/en-US/index.html) is unreadable because the sidebar obscures the text in the main body.

Version-Release number of selected component (if applicable):
publican-doc-0.39-0.fc10.noarch
firefox-3.0.4-1.fc10.x86_64

How reproducible:
100%

Steps to Reproduce:
1.Applications->Other->Publican
2.
3.
  
Actual results:
firefox is started with file:///usr/share/doc/publican-doc-0.39/en-US/index.html
See screen capture.

Expected results:


Additional info:
Comment 1 Jeff Fearn 2008-12-17 16:39:37 EST
(In reply to comment #0)
> Created an attachment (id=327272) [details]
> screen-grab of the problem
> 
> Description of problem:
> The User Guide (file:///usr/share/doc/publican-doc-0.39/en-US/index.html) is
> unreadable because the sidebar obscures the text in the main body.
> 
> Version-Release number of selected component (if applicable):
> publican-doc-0.39-0.fc10.noarch
> firefox-3.0.4-1.fc10.x86_64
> 
> How reproducible:
> 100%
> 
> Steps to Reproduce:
> 1.Applications->Other->Publican
> 2.
> 3.
> 
> Actual results:
> firefox is started with
> file:///usr/share/doc/publican-doc-0.39/en-US/index.html
> See screen capture.

Can anyone duplicate this behaviour?

Works for me on:

$ rpm -q  publican-doc firefox
publican-doc-0.39-0.fc10.noarch
firefox-3.0.4-1.fc10.x86_64
Comment 2 John Ellson 2008-12-17 23:14:27 EST
Further investigation shows that this is related to my use of a 12pt minimimum font size in:
    Edit->Preferences->Content->Fonts&Colors->Advanced

The sizes of the fonts themselves don't seem to matter, just the minimum size.

I guess this is a firefox bug then?
Comment 3 Jeff Fearn 2008-12-18 00:57:36 EST
(In reply to comment #2)
> Further investigation shows that this is related to my use of a 12pt minimimum
> font size in:
>     Edit->Preferences->Content->Fonts&Colors->Advanced
> 
> The sizes of the fonts themselves don't seem to matter, just the minimum size.
> 
> I guess this is a firefox bug then?

It's due to the way the style sheet layouts out the column widths. Changing the size of the font in one area without a relative change in another area means the width doesn't get adjusted in a relative fashion and the overlap occurs.

Disabling the minimum font size and hitting '+' to increase the font size scales correctly.

Disabling CSS scales correctly.

This one will take a bit of thinking to fix :)
Comment 4 John Ellson 2008-12-18 12:03:58 EST
Yes, ctrl-shift-+ works, but this zoomed state is per URL, so change to a different URL and its unreadable again.

Setting all fonts to 16pt, and disabling "allow pages to set own fonts"
seems to be totally ignored.   Font size looks to be about 8pt.

xdpyinfo returns reasonable results  96dpi.

Why does minimimum font size not apply to all areas in CSS?

Seems like minimimum font size was calculated differently into the column width than it was into the font size (note extra space on right of text in sidebar).
Comment 5 Jeff Fearn 2008-12-18 16:36:46 EST
(In reply to comment #4)
> Yes, ctrl-shift-+ works, but this zoomed state is per URL, so change to a
> different URL and its unreadable again.
>
> Setting all fonts to 16pt, and disabling "allow pages to set own fonts"
> seems to be totally ignored.   Font size looks to be about 8pt.
>
> xdpyinfo returns reasonable results  96dpi.
> 
> Why does minimimum font size not apply to all areas in CSS?

The minimum does apply across all areas of the CSS, however only some areas in the CSS have a font size that calculates to less than 12pt and only those areas have their font size increased by setting minimum font size.

This is what leads to only those parts with small font sizes having their width, margin and padding increased.

> Seems like minimimum font size was calculated differently into the column width
> than it was into the font size (note extra space on right of text in sidebar).

When FF finds an area that has a font size less than the minimum it only increases the font size in that area.

It would be nice if it had an option to increase all font sizes proportionally until the smallest font size was the minimum ... but it doesn't, so I will have to find another solution :)

Cheers, Jeff.
Comment 6 Jeff Fearn 2009-01-06 01:42:48 EST
Removed override of font size in TOC and reduced white space around TOC to balance out font size increase.
Comment 7 Fedora Update System 2009-01-16 02:40:38 EST
publican-fedora-0.17-0.fc10,publican-0.40-0.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/publican-fedora-0.17-0.fc10,publican-0.40-0.fc10
Comment 8 Fedora Update System 2009-01-16 02:43:24 EST
publican-fedora-0.17-0.fc9,publican-0.40-0.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/publican-fedora-0.17-0.fc9,publican-0.40-0.fc9
Comment 9 Fedora Update System 2009-01-21 16:32:52 EST
publican-fedora-0.17-0.fc10, publican-0.40-0.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.