Bug 476909 - Nautilus says "Internal error: No mount object for mounted volume", but volume mounted nonetheless
Nautilus says "Internal error: No mount object for mounted volume", but volum...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Tomáš Bžatek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-17 16:55 EST by James
Modified: 2015-03-03 17:33 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-21 02:58:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 549946 None None None Never
Launchpad 256749 None None None Never

  None (edit)
Description James 2008-12-17 16:55:47 EST
Description of problem:
Mounting a volume by double-clicking on its icon in the Nautilus Computer window result in the cryptic error message "Internal error: No mount object for mounted volume".

Version-Release number of selected component (if applicable):
nautilus-2.24.2-1.fc10.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. Log out and log in to a fresh session.
2. Insert a USB stick, wait until it mounts.
3. Unmount it.
4. Open up Computer in Nautilus, double-click on the stick.

At this point, I get the error message described above. However the drive is properly mounted.

5. Close the Computer window.

Repeating steps 3--5 above keeps bringing up the error message. However, if I unmount the drive, and mount the stick by *right-clicking* on its icon and choosing Mount Volume in the menu, I see no error message and the volume mounts fine.
Comment 1 Matt McCutchen 2009-01-13 02:12:46 EST
I see the same behavior when I double-click the icon in Computer for my LUKS-encrypted external hard drive.  I have the hidden gconf keys /desktop/gnome/volume_manager/automount_{drives,media} set to false, so when I connect the drive, it appears in Computer but doesn't mount automatically.

I imagine the reason why the "Mount Volume" menu option doesn't give the error is that the menu option only mounts, but a double-click mounts and then opens.  Perhaps whatever backend process is implementing the mount reports completion to Nautilus before the "mount object" is actually ready, so there is a race.  If the error occurs only some of the time or only with certain drives (slow ones?), that would be consistent with there being a race.
Comment 2 James 2009-04-10 09:54:09 EDT
I've not seen this in nautilus-2.26.1-2.fc11.x86_64, can a fix feed its way back to F10?
Comment 3 James 2009-07-28 11:16:38 EDT
Matt, this is fixed for me in F11 which I'm now using. Do you have any objections to me closing it?
Comment 4 Matt McCutchen 2009-08-20 22:59:58 EDT
The problem is gone for me in F11 too.  Go ahead and close the bug as CURRENTRELEASE (I suppose).

Note You need to log in before you can comment on or make changes to this bug.