Bug 476929 - WLAN on boot breaks GDM/greeter
WLAN on boot breaks GDM/greeter
Status: CLOSED DUPLICATE of bug 441453
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
10
All Linux
low Severity high
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-17 20:59 EST by kevin.t.bowen
Modified: 2009-04-17 17:32 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-17 17:32:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description kevin.t.bowen 2008-12-17 20:59:13 EST
Description of problem:
Enabling the new system-connections feature (with the keyfile plugin) on a wireless connection causes GDM to fail on boot (X loads, but the cursor spins endlessly, greeter never comes up). Logs indicate gnome-settings-daemon etc being unable to connect to display :0

As a test, I tried the identical configuration, but with a wired connection, and everything worked, so I think what's happening is that the longer time it takes to bring up wireless vs wired results in the connection being in partially-connected state when GDM starts.

If I boot into runlevel 3, wait for NM to finish brining up the connection, then telinit to runlevel 5, it works, which seems to confirm the above suspicion.

Version-Release number of selected component (if applicable):
NetworkManager-0.7.0-0.12.svn4326.fc10.i386
gdm-2.24.0-12.fc10.i386

How reproducible:
Always

Steps to Reproduce:
1. Change /etc/NetworkManager/nm-system-settings.conf to read "plugins=keyfile"
2. Apply appropriate PolicyKit voodoo 
3. reboot
3. In nm-connection-editor, check "available to all users" and "connect automatically" on a wireless connection.
4. reboot

Actual results:
GDM's X session loads, but the greeter never comes up.

Expected results:
GDM greeter, successful login, world peace.

Additional info:

I'm not sure whether this bug should be filed against GDM in addition to/instead of NetworkManager.... or is it gnome-session, Xorg, something else?

Sample log entries:
-/var/log/gdm/:0.log:
AUDIT: Wed Dec 17 16:49:55 2008: 2133 Xorg: client 8 rejected from local host ( uid=42 gid=42 pid=2288 )

-/var/log/gdm/:0-greeter.log:
Window manager warning: Failed to read saved session file /var/lib/gdm/.config/metacity/sessions/107defc4414717b4f51229561347$
** (process:2299): DEBUG: Greeter session pid=2299 display=:0.0 xauthority=/var/run/gdm/auth-for-gdm-E8x3L6/database
No protocol specified
gdm-simple-greeter[2299]: Gtk-WARNING: cannot open display: :0.0
Comment 1 Dan Williams 2009-02-13 07:17:54 EST
This is probably hostname related; GDM doesn't handle hostname changes very well.  Could you try assigning a hostname in /etc/sysconfig/network like so?

HOSTNAME=mycomputer

and then see if this problem continues?
Comment 2 Jessica Sterling 2009-03-06 17:22:55 EST
This bug has been triaged

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 3 Paul Jenner 2009-04-17 15:03:04 EDT
Duplicate of #441453?
Comment 4 Dan Williams 2009-04-17 17:32:19 EDT
yeah, probably

*** This bug has been marked as a duplicate of bug 441453 ***

Note You need to log in before you can comment on or make changes to this bug.