This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 476933 - mock uses deprecated popen2 module
mock uses deprecated popen2 module
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: mock (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-17 21:33 EST by Matt Domsch
Modified: 2013-01-09 23:59 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-05 18:22:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Domsch 2008-12-17 21:33:46 EST
Description of problem:
mock in rawhide throws this warning on every invocation due to changes in python 2.6.  The code should be converted to use subprocess instead of popen2.

/usr/lib/python2.6/site-packages/mock/util.py:13: DeprecationWarning: The popen2 module is deprecated.  Use the subprocess module.
  import popen2


Version-Release number of selected component (if applicable):
mock-0.9.13-2.fc11.noarch

How reproducible:
always

Steps to Reproduce:
1. build something with mock
  
Actual results:
see the warning

Expected results:
no warning
Comment 1 Clark Williams 2008-12-18 10:17:53 EST
actually, that's just a left-over from a previous incarnation. All process manipulation actually does use the subprocess module.

I'll delete the import of popen2 from util.py.
Comment 2 Clark Williams 2009-02-05 18:22:17 EST
fixed in current release
(0.9.14-1)

Note You need to log in before you can comment on or make changes to this bug.