Bug 476934 - autofs starts before ypbind, so isn't using NIS-provided automount maps
autofs starts before ypbind, so isn't using NIS-provided automount maps
Status: CLOSED DUPLICATE of bug 475002
Product: Fedora
Classification: Fedora
Component: autofs (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Ian Kent
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-17 21:45 EST by Matt Domsch
Modified: 2009-01-06 00:25 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-06 00:25:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Domsch 2008-12-17 21:45:02 EST
Description of problem:
Both autofs and ypbind in rawhide (pre-F11) start with priority 28, but autofs is alphabetically before ypbind, so it starts before ypbind.  This means autofs is not picking up any NIS-provided automount maps like it should.

Simply changing the priority in /etc/rc.d/init.d/autofs likely isn't the solution, as ypbind asks for a priority of 27, but is getting assigned a priority of 28 which then causes the conflict with autofs.

Version-Release number of selected component (if applicable):
autofs-5.0.4-4.x86_64
ypbind-1.20.4-11.fc11.x86_64
chkconfig-1.3.40-1.x86_64

How reproducible:
easy

Steps to Reproduce:
1. install rawhide, requesting autofs and ypbind in your package list
  
Actual results:
see both start with S28, but autofs starts first.


Expected results:
autofs starts after ypbind finishes
Comment 1 Jeff Moyer 2009-01-05 12:48:47 EST
Ian, is this a duplicate?
Comment 2 Ian Kent 2009-01-06 00:24:51 EST
This is the second time we've seen this reported but we can't see
a problem with the init script indexes in current CVS. Please have
look though bug 475002 and add further findings to it.
Comment 3 Ian Kent 2009-01-06 00:25:22 EST

*** This bug has been marked as a duplicate of bug 475002 ***

Note You need to log in before you can comment on or make changes to this bug.