Bug 476935 - Total disk statistics include partition counters (double count) on kernel 2.6.25+
Total disk statistics include partition counters (double count) on kernel 2.6...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: dstat (Show other bugs)
10
All Linux
low Severity urgent
: ---
: ---
Assigned To: Zdenek Prikryl
Fedora Extras Quality Assurance
http://svn.rpmforge.net/viewvc/trunk/...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-17 22:27 EST by Dag Wieers
Modified: 2008-12-24 13:48 EST (History)
1 user (show)

See Also:
Fixed In Version: 0.6.9svn
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-24 13:48:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dag Wieers 2008-12-17 22:27:42 EST
Description of problem:
Because of changes to the proc interface total disk counts include disk partitions counters, causing double counts in those numbers.

This is causing wrong numbers in a lot of use-cases.


Version-Release number of selected component (if applicable):
0.6.9 and older. A patch for this is in subversion.


How reproducible:



Steps to Reproduce:
1. dstat -td -D total,sda,hda,sdb
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Fedora Update System 2008-12-23 06:48:03 EST
dstat-0.6.8-2.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/dstat-0.6.8-2.fc10
Comment 2 Fedora Update System 2008-12-24 13:48:09 EST
dstat-0.6.8-2.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.