Bug 476941 - Failure to restore the failed paths on restoring the array controller [NEEDINFO]
Failure to restore the failed paths on restoring the array controller
Status: CLOSED DUPLICATE of bug 500729
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: device-mapper-multipath (Show other bugs)
5.1.z
All Linux
low Severity medium
: rc
: ---
Assigned To: Ben Marzinski
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-18 01:46 EST by vijay
Modified: 2010-07-27 15:27 EDT (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-27 15:27:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
bmarzins: needinfo? (vijayakumar)


Attachments (Terms of Use)

  None (edit)
Description vijay 2008-12-18 01:46:42 EST
Description of problem:
on controller failure, the I/Os are failover to the available paths and
corresponding sas devices of the failed paths are removed. on re-enabling the
controller, not all the failed paths are failed back. 
Subsequent failure of the other controller, results in all path failure
condition( since it failed to failback the failed paths in previous step)
and read/write error for the luns are observed. 

Version-Release number of selected component (if applicable):
 Array: MSA 2000 with SAS connectivity(MSA2012sa), dual controller 
 Array firmware : J300p10
 mptsas driver version: mptlinux-3.12.14.00-2
 Number of luns presented to host: 15

How reproducible:
Frequently

Steps to Reproduce:
1. Fail one of Array controller, I/Os are failover to available paths.
2. Enable the failed array controller, all failed paths are not restored
3. Fail other array controller.
4. Read/write error to the SAS devices are observed.
  
Actual results:
On Enabling the failed array controller, not all failed paths are failed back. 

Expected results:
On Enabling the failed array controller, all failed paths needs to be enabled.

Additional info:
On heavy load, the DM generated uevents to add/remove the maps/paths are
delayed. Few of the uevents are lost which results in the failure to fail back
the failed paths.


Thanks!
Comment 2 Ben Marzinski 2010-07-27 15:27:45 EDT
This bug appears to have been solved by bz 500729.  If you are still able to reproduce this using kernel-2.6.18-162.el5 or a more recent kernel, please reopen this bug.

*** This bug has been marked as a duplicate of bug 500729 ***

Note You need to log in before you can comment on or make changes to this bug.