Bug 476949 - [fix available] Crash when Presentation monitor of slide show is different from monitor where OOo started
[fix available] Crash when Presentation monitor of slide show is different fr...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: openoffice.org (Show other bugs)
5.2
All Linux
low Severity medium
: rc
: ---
Assigned To: David Tardon
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-18 04:25 EST by Toralf
Modified: 2010-03-30 04:45 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-30 04:45:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg config file for dual-screen setup (2.47 KB, text/plain)
2008-12-18 04:25 EST, Toralf
no flags Details
patch (3.27 KB, patch)
2009-08-20 01:17 EDT, David Tardon
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 85273 None None None Never

  None (edit)
Description Toralf 2008-12-18 04:25:51 EST
Created attachment 327311 [details]
xorg config file for dual-screen setup

Description of problem:
I recently experienced some slight embarrassment during a presentation because I tried running Impress on a projector set up as an X screen separate from the built-in monitor on my laptop. To make a long story short, there was no way I could run my slideshow on the projector - OpenOffice.org would just exit when selecting Slide Show->Slide Show.


Version-Release number of selected component (if applicable):
2.3.0-6.5.4.el5

How reproducible:
Every time

Steps to Reproduce:
1. Set up a dual-display PC to run the GUI as two separate desktops on individual X screens...
2. Enter the desktop that's NOT the main one (i.e. screen #1)
3. Start openoffice.org, and open an Impress file
4. Select Slide Show->Slide Show (or press F5) 
  
Actual results:
OOo exits with an X error. The main desktop (screen #0) flashes slightly as this happens, so OOo may be trying to run the slide show on the wrong screen. Error message is:
X-Error: BadMatch (invalid parameter attributes)
        Major opcode: 155
        Minor opcode: 8
        Resource ID:  0x4a01a17
        Serial No:    36125 (36125)
These errors are reported asynchronously,
set environment variable SAL_SYNCHRONIZE to 1 to help debugging

Expected results:
Slideshow runs.

Additional info:
I'm using an NVIDIA graphics card with driver from NVIDIA. X config is attached.
Comment 1 Toralf 2008-12-18 04:41:27 EST
Ooops. 10 seconds after I submitted that report it occurred to me that the slide show perhaps runs on a specific monitor configured in the presentation options, and not generally the one where you started openoffice.org (as I assumed earlier.) And indeed, I had the slide show set up to run on screen #0 a.k.a. "Monitor 1", so OOo was right to try to display the slides there. This means I have encountered a slightly different issue from the one I originally thought, but it still looks like a bug. The problem is in fact running a slide-show on a different screen from the one where openoffice.org started. The following scenario is probably more interesting than the one described earlier

1. Set up a dual-display PC to run the GUI as two separate desktops on
individual X screens...
2. Start openoffice.org on the main desktop, and open an Impress file.
3. Select Slide Show->Slide Show settings.
4. In the "Presentation monitor" menu under "Multiple monitors", select "Monitor 2". Then hit OK.
5. Start the slide show.

Actual results:
As described earlier.
Comment 2 Toralf 2008-12-18 04:44:06 EST
Subject changed. Was:

Slide show on screen #1 crashes OOo
Comment 3 David Tardon 2009-08-20 01:17:45 EDT
Created attachment 358035 [details]
patch
Comment 5 koka xiong 2010-01-11 04:39:42 EST
Verified with openoffice.org-3.1.1-19.5.el5 on
Red Hat Enterprise Linux 5Client - i386, x86_64
Red Hat Enterprise Linux 5Server-i386, x86_64

test steps:
1. Set up a dual-display PC to run the GUI as two separate desktops on
individual X screens...
2. Start openoffice.org on the main desktop, and open an Impress file.
3. Select Slide Show->Slide Show settings.
4. In the "Presentation monitor" menu under "Multiple monitors", select
"Monitor 2". Then hit OK.
5. Start the slide show.

No crash is found.Verification is passed.
Comment 7 errata-xmlrpc 2010-03-30 04:45:28 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0274.html

Note You need to log in before you can comment on or make changes to this bug.