Bug 476963 - Can't copy HTML email content - Evolution crashes when selecting text in HTML mail for copy
Can't copy HTML email content - Evolution crashes when selecting text in HTML...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
9
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-18 05:59 EST by Gerard Fernandes
Modified: 2009-03-07 12:45 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-07 12:45:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gerard Fernandes 2008-12-18 05:59:39 EST
Description of problem: Evolution crashes when selecting text in HTML mail for copy


Version-Release number of selected component (if applicable): latest fully updated Fedora-9 (stable repositories only)


How reproducible: Always


Steps to Reproduce:
1. Configure Evolution to access Google mail via IMAP
2. Send yourself an HTML email to the google mail address preferably from another email address - or simply use an existing HTML formatted email.
3. Open this email, attempt to select all content for copying. At this point Evolution crashes.
  
Actual results: Boom!


Expected results: Selected content - preferably highlighted - on which the user can execute Cntrl-C (or Edit/Copy) to copy all content.


Additional info:
Comment 1 Gerard Fernandes 2008-12-18 06:01:30 EST
Since I only ever use Evolution to access google mail via IMAP (don't run my own mail server!), I can't say if this is applicable to all HTML email or to HTML email accessed specifically via IMAP.
Comment 2 Milan Crha 2008-12-18 06:40:34 EST
Could you install debug info packages for evolution, evolution-data-server and gtkhtml3, and attach here also a stacktrace of the crash, please? Thanks in advance. It'll help to identify the place where it crashed. Maybe also how you select the text exactly? You can by mouse, with arrows and shift, the Ctrl+A, and so on. Maybe it also depends on the message structure, like tables, paragraphs,...

But let's see the trace first, maybe it was already reported.
Comment 3 Gerard Fernandes 2009-01-05 07:39:00 EST
Sorry for the long delay in getting back - Christmas, New Year and a Fedora upgrade to v10 intervened. :)

I've just upgraded to Fedora 10, where this problem still happens. The only difference is that it does allow the GNOME bug-reporter to send off details. I have done that and will post another comment with the GNOME bug reference number.

The copying may be done in any manner - with either Cntrl-A, only the mouse, partial mouse/keyboard (with arrows and shift) - all with the same result. The moment the Cntrl-C combination is used (or the Edit/Copy menu option selected), Evolution gives up the ghost.
Comment 4 Gerard Fernandes 2009-01-06 02:38:50 EST
The last post is a little misleading - I'd assumed that all the methods for selecting content for copying would work (e.g. Cntrl-A, shift key + arrows etc.).

I just tried it and as it turns out, there is really only one way to select text: with the mouse. NO OTHER METHOD WORKS!

1. Cntrl-A selects all the emails from the summary window EVEN WHEN FOCUSSED ON THE MAIL CONTENT DISPLAY WINDOW! When the mail is opened in a separate window nothing happens at all when selecting Cntrl-A.

2. Shift and the arrow keys do nothing at all for selecting text in either the embedded mail display window or when the mail is opened in a separate window.

I'm on the latest updated Fedora 10.
Comment 5 Milan Crha 2009-01-06 06:59:37 EST
Try Edit->Select all text. It has different shortcuts because it collides with those for a mail window, as you said above. There is also a difference between composer and viewer of the mail, and I believe it's correct. You can turn on the caret mode (View->Caret Mode) to be able to select with text as you described in 2), but I cannot recommend it, unfortunately, it has some strangeness too.
Comment 6 Gerard Fernandes 2009-01-06 17:50:48 EST
Edit/Select All Text crashes Evolution as well. Here is the crash report link:
http://crash.gnome.org/report/index/24c5ed00-dc44-11dd-aa67-0007e9333148?date=2009-01-06-22
Comment 7 Mike Chambers 2009-03-07 10:01:56 EST
Does this problem still persist?  Does it happen on a new user as well? BTW, this doesn't seem to happen (well, not tested on imap, but on pop3 connection) on latest evo in rawhide.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 8 Gerard Fernandes 2009-03-07 11:24:31 EST
Sorry, I've done a couple of updates and not tested this. With my current system (all patches applied as of 6th March 2009), I can confirm that this problem doesn't persist.

I've tested with various HTML emails I have in my IMAP mail-box and it works as expected - the text is copied to the clip-board from where it may be transfered to any other application.

Note You need to log in before you can comment on or make changes to this bug.