Bug 476985 - (CVE-2008-5624) CVE-2008-5624 php: missing initialization of BG(page_uid) and BG(page_gid)
CVE-2008-5624 php: missing initialization of BG(page_uid) and BG(page_gid)
Status: CLOSED DUPLICATE of bug 169857
Product: Security Response
Classification: Other
Component: vulnerability (Show other bugs)
unspecified
All Linux
low Severity low
: ---
: ---
Assigned To: Red Hat Product Security
http://nvd.nist.gov/nvd.cfm?cvename=C...
source=internet,reported=20081204,pub...
: Security
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-18 09:44 EST by Tomas Hoger
Modified: 2009-02-26 16:31 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-26 16:29:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Hoger 2008-12-18 09:44:33 EST
Common Vulnerabilities and Exposures assigned an identifier CVE-2008-5624 to the following vulnerability:

PHP 5 before 5.2.7 does not properly initialize the page_uid and
page_gid global variables for use by the SAPI php_getuid function,
which allows context-dependent attackers to bypass safe_mode
restrictions via variable settings that are intended to be restricted
to root, as demonstrated by a setting of /etc for the error_log
variable.

References:
http://securityreason.com/achievement_securityalert/59
http://www.securityfocus.com/archive/1/archive/1/498985/100/0/
http://www.php.net/ChangeLog-5.php#5.2.7
http://www.securityfocus.com/bid/32688
http://xforce.iss.net/xforce/xfdb/47318
Comment 5 Josh Bressers 2009-02-26 16:29:17 EST

*** This bug has been marked as a duplicate of bug 169857 ***

Note You need to log in before you can comment on or make changes to this bug.