Bug 477001 - ext4: "No space left on device" incorrectly reported
ext4: "No space left on device" incorrectly reported
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
i686 Linux
high Severity high
: ---
: ---
Assigned To: Eric Sandeen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-18 10:42 EST by Evan McNabb
Modified: 2009-03-11 23:02 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-11 23:02:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
tune2fs output (1.73 KB, text/plain)
2008-12-22 17:02 EST, Evan McNabb
no flags Details

  None (edit)
Description Evan McNabb 2008-12-18 10:42:38 EST
Description of problem:
The root filesystem on my Fedora 10 laptop is ext4. Multiple times now (every few days it seems like) the filesystem reports back there is no space left on the device, even though that's not the case. If I reboot the filesystem goes back to a normal state:

# touch /testfile.txt
touch: cannot touch `/testfile.txt': No space left on device
# mount
/dev/mapper/vg01-lv01 on / type ext4 (rw)
...
# df
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/mapper/vg01-lv01 15094792   4865328   9462696  34% /
...
# df -i
Filesystem            Inodes   IUsed   IFree IUse% Mounted on
/dev/mapper/vg01-lv01 958464  192170  766294   21% /
...

I do not see any errors in dmesg that are related to this.

Version-Release number of selected component (if applicable):
kernel-2.6.27.7-134.fc10.i686

How reproducible:

I have not noticed any usage pattern that triggers this. In my most recent case the laptop had been on for only a few minutes.

There is a suspend to RAM bug I'm fighting right now that often makes me hard poweroff my laptop, so that could possibly be a factor (although the filesystem always comes up fine after boot).

Additional info:

I'm attaching the tune2fs output at the time of occurrence.
Comment 1 Evan McNabb 2008-12-22 17:02:57 EST
Created attachment 327701 [details]
tune2fs output
Comment 2 Eric Sandeen 2009-01-05 15:26:06 EST
Evan, thanks, there are some known space-accounting problems yet... though also, I wonder about a patch I had in there causing problems.  The patch got inadvertently dropped, though, so we have an accidental chance to check something.  :)  Do you see the problem with, say, 2.6.27.8-140 and later?
Comment 3 Evan McNabb 2009-01-05 16:56:12 EST
I upgraded to 2.6.27.9-159.fc10 on Dec 26th and I don't remember experiencing this since then. Definitely not in the last week. I'll keep watching for it to occur and will let you know if it does.
Comment 4 Evan McNabb 2009-01-22 13:51:31 EST
Hi Eric,
I haven't seen this problem since upgrading to 2.6.27.9-159.fc10 which was almost a month ago. I'm fine with closing this bug if you'd like.
Comment 5 Eric Sandeen 2009-03-11 23:02:15 EDT
There was a bug in the inode allocator that was the most likely cause of this; it was fixed as of 2.6.29-0.122.rc5; I'm going to close on that assumption.

Thanks for the report, and sorry it took a while to track down :)

Note You need to log in before you can comment on or make changes to this bug.