Bug 477024 - Feedparser.py: Unicode parsing error when reading questionable RSS in podcast feed
Summary: Feedparser.py: Unicode parsing error when reading questionable RSS in podcast...
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: python-feedparser   
(Show other bugs)
Version: rawhide
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Konstantin Ryabitsev
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Patch
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-12-18 18:26 UTC by Ted Roche
Modified: 2009-01-16 23:48 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-16 23:47:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ted Roche 2008-12-18 18:26:33 UTC
Description of problem: Unicode parsing error when reading questionable RSS in podcast feed

Version-Release number of selected component (if applicable): 4.1
 from feedparser.py:

__version__ = "4.1"# + "$Revision: 1.92 $"[11:15] + "-cvs"

How reproducible: 100%

Steps to Reproduce:
1. start python
2. import feedparser
3. feedparser.parse('http://feeds.feedburner.com/railsenvy-podcast')
  
Actual results:

UnicodeDecodeError: 'utf8' codec can't decode byte 0xbb in position 12: unexpected code byte


Expected results:

Successful parsing.

Additional info: see http://code.google.com/p/feedparser/issues/detail?id=128 for documentation on other distros and a working patch.

Also causes gPodder to fail to import some Podcast RSS (like the one above) because it uses the same parsing functions.

Comment 1 Rex Dieter 2008-12-18 18:47:06 UTC
triaged.

Comment 2 Fedora Update System 2008-12-27 18:54:44 UTC
python-feedparser-4.1-5.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/python-feedparser-4.1-5.fc9

Comment 3 Fedora Update System 2008-12-27 18:54:48 UTC
python-feedparser-4.1-5.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/python-feedparser-4.1-5.fc10

Comment 4 Fedora Update System 2008-12-30 23:54:15 UTC
python-feedparser-4.1-5.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update python-feedparser'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2008-11945

Comment 5 Fedora Update System 2008-12-30 23:54:18 UTC
python-feedparser-4.1-5.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing-newkey update python-feedparser'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-11946

Comment 6 Fedora Update System 2009-01-16 23:47:23 UTC
python-feedparser-4.1-5.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2009-01-16 23:48:51 UTC
python-feedparser-4.1-5.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.