Bug 477048 - update xorg-x11-drv-ati-6.9.0-62.fc10.i386 breaks Radeon RV250
update xorg-x11-drv-ati-6.9.0-62.fc10.i386 breaks Radeon RV250
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
10
i386 Linux
low Severity high
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-18 15:49 EST by Maurizio Paolini
Modified: 2008-12-22 07:09 EST (History)
5 users (show)

See Also:
Fixed In Version: xorg-x11-drv-ati-6.9.0-63
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-22 07:09:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log with the final error (101.73 KB, text/plain)
2008-12-18 16:19 EST, Hubert Verstraete
no flags Details

  None (edit)
Description Maurizio Paolini 2008-12-18 15:49:36 EST
Description of problem:

Both kde and gnome grawl to a halt (login becomes impossible) after
update from xorg-x11-drv-ati-6.9.0-61.fc10.i386 to xorg-x11-drv-ati-6.9.0-62.fc10.i386.

Version-Release number of selected component (if applicable):

xorg-x11-drv-ati-6.9.0-62.fc10.i386

How reproducible:

kdm greet screen does not complete and everything halts

Steps to Reproduce:
1. update xorg-x11-drv-ati to 6.9.0-62
2. telinit 3, then telinit 5
  
Actual results:

screen freezes or slows down to an almost halted state

Additional info:

after replacing /usr/lib/xorg/modules/drivers/radeon_drv.so
with the corresponding file from the 6.9.0.61 package everything
works as before the update.
Comment 1 Hubert Verstraete 2008-12-18 16:12:56 EST
exactly the same bug since I upgraded today to 6.9.0-62
I've had to move to the vesa driver on 2 computers with 2 different ATI cards.
The card on this computer is ATI Technologies Inc RV350 AP [Radeon 9600].
I don't understand how this update came out from the testing repository ...
Comment 2 Hubert Verstraete 2008-12-18 16:19:04 EST
Created attachment 327367 [details]
Xorg.0.log with the final error

It ends with
(EE) RADEON(0): FIFO timed out, resetting engine...
Comment 3 Maurizio Paolini 2008-12-18 17:08:50 EST
(In reply to comment #1)
> exactly the same bug since I upgraded today to 6.9.0-62
> I've had to move to the vesa driver on 2 computers with 2 different ATI cards.
> The card on this computer is ATI Technologies Inc RV350 AP [Radeon 9600].
> I don't understand how this update came out from the testing repository ...

If it helps I placed the previous /usr/lib/xorg/modules/drivers/radeon_drv.so
in http://dmf.unicatt.it/~paolini/radeon/
By chance I didn't upgrade also the computer at work, so I still had
the old version there :-)

Actually this was a *very annoying* problem!
Comment 4 Leam 2008-12-19 05:45:22 EST
IBM T30 loses all fonts at run level 5. Can't even read the login screen though blind-typing lets me log in and do stuff. Run Level 3 and grub booting fine. Here's the chipset info from the Xorg.0.log:

RADEON(0): Chipset: "ATI Radeon Mobility M7 LW (AGP)" (ChipID = 0x4c57)

Reverting to -61 fixed the issue.
Comment 5 Fredrik Öhrn 2008-12-20 16:34:24 EST
The -62 driver causes the display to go weird on my Dell D600 with a Mobility Radeon 9000 chipset as well, especially text is jumbled beyond recognition.

Downgrading to -61 fixed it, it's mostly gone from the mirrors but can be found here: http://koji.fedoraproject.org/koji/buildinfo?buildID=72791
Comment 6 Richard Burnison 2008-12-21 16:07:41 EST
As mentioned, the ATI Radeon 9600 experiences the same symptoms after upgrading to xorg-x11-drv-ati-6.9.0-62.fc10.i386.  In addition to the timeout listed in Xorg.0.log, an error is logged in messages, excerpted below:

Dec 20 13:11:55 localhost kernel: Linux agpgart interface v0.103
Dec 20 13:11:55 localhost kernel: agpgart-intel 0000:00:00.0: Intel 865 Chipset
Dec 20 13:11:55 localhost kernel: agpgart-intel 0000:00:00.0: AGP aperture is 64M @ 0xac000000
...
Dec 20 13:11:55 localhost kernel: [drm] Initialized drm 1.1.0 20060810
Dec 20 13:11:55 localhost kernel: pci 0000:01:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
Dec 20 13:11:55 localhost kernel: [drm] Forcing AGP to PCI mode
Dec 20 13:11:55 localhost kernel: [drm] Initialized radeon 1.29.0 20080528 on minor 0
...
Dec 20 13:12:08 localhost kernel: agpgart-intel 0000:00:00.0: AGP 3.0 bridge
Dec 20 13:12:08 localhost kernel: agpgart-intel 0000:00:00.0: putting AGP V3 device into 8x mode
Dec 20 13:12:08 localhost kernel: pci 0000:01:00.0: putting AGP V3 device into 8x mode
Dec 20 13:12:09 localhost kernel: [drm:radeon_do_init_cp] *ERROR* PCI GART memory not allocated!

When using the proprietary ATI driver, the symptoms do not arise; however, this is not a feasible workaround, as several applications, including OpenOffice, do not seem to function.
Comment 7 Dave Airlie 2008-12-21 18:43:19 EST
please test with the xorg-x11-drv-ati-6.9.0-63 in koji.

I see two problems here, one is already fixed in a later kernel update, without that fix the fallback position was broken in -62. So -63 should fix the fallback position.
Comment 8 Maurizio Paolini 2008-12-21 20:22:29 EST
(In reply to comment #7)
> please test with the xorg-x11-drv-ati-6.9.0-63 in koji.
> 
> I see two problems here, one is already fixed in a later kernel update, without
> that fix the fallback position was broken in -62. So -63 should fix the
> fallback position.

Tested.  All seems fine now, thank you very much!
Comment 9 Hubert Verstraete 2008-12-22 03:44:56 EST
works fine here too. Thanks.
Comment 10 Fredrik Öhrn 2008-12-22 04:05:19 EST
Great! The new build works fine here.
Comment 11 Leam 2008-12-22 04:38:27 EST
Works fine here, thanks!

Note You need to log in before you can comment on or make changes to this bug.